Hello Guest it is July 20, 2019, 08:16:16 AM

Author Topic: Jog not working?  (Read 4631 times)

0 Members and 1 Guest are viewing this topic.

Jog not working?
« on: June 28, 2012, 08:36:55 AM »
I have been experiencing problems with Jogging..The display doesnt appear on my screen. It outright doesn't work..shortcuts or clicking the control to it...It doesn't work at all. Any ideas would be usefull.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Jog not working?
« Reply #1 on: June 28, 2012, 08:52:22 AM »
Hard to say what your problem is as I dont really understand what you are meaning, can you try and explain a bit clearer as to what your issue is?
Hood
Re: Jog not working?
« Reply #2 on: June 28, 2012, 09:49:01 AM »
Don't know if this is your problem, but I had a similar situation just the other day.  Jogging with the arrow keys stopped working.  I tried the Tab key to bring up the Jog panel and that didn't work either.  I was baffled for quite some time.

What I found was that my program had inadvertently generated a "Soft Limit Warning".  When this happens, a dialog box appears asking if you want to continue or not.  This dialog box had somehow been shuffled "behind" the main Mach screen.  It was waiting for a response and nothing in Mach was going to work until this dialog box was addressed.  Once I clicked Continue on the "Soft Limit Warning", everything was fine.
Bill (the Cat) Shubert
Re: Jog not working?
« Reply #3 on: July 01, 2012, 03:45:18 PM »
Just got the same type issue, the keyboard arrow keys will not jog the x or y, page up/down still moves the z. using the mouse the machine will move to the park and tool change positions. Have reset the computer and such but the issue still persists. Any ideas......

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Jog not working?
« Reply #4 on: July 01, 2012, 03:49:29 PM »
Go to Config menu then System Hotkeys and see whats set there, Should be like attached pic. If its not click on X++ and right arrow key, X-- and Left arrow key, Y++ and Up arrow, Y-- and down arrow.
Hood
Re: Jog not working?
« Reply #5 on: July 01, 2012, 05:17:53 PM »
Thanks Hood for a point in the right direction. For some reason the hotkeys reset? Reconfigured them and all is well.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Jog not working?
« Reply #6 on: July 01, 2012, 05:36:31 PM »
I have seen a few mentions of that happening over the years, why I dont know, has never happened to me.
Hood
Re: Jog not working?
« Reply #7 on: June 19, 2013, 03:34:13 AM »
Dear hood, i am newbie in cnc. My new bought cnc jog key can move fine in step mode, but not in Jog continue mode. When i click Jog continue for any axis motor just turn a bit. If i keep press hold the Jog key, still same move once only. Look like inching movement, when i do it offline the mach3 run well with continue increase the position. This was happen in ref all home too, only Z axis move a bit then hang up there, need to press Emergency stop to reset. Hope to get the mach prof. advice..... Thank you.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Jog not working?
« Reply #8 on: June 19, 2013, 04:40:36 AM »
Attach your xml and I will have a look.
Hood
Re: Jog not working?
« Reply #9 on: June 19, 2013, 10:11:57 PM »
 ??? Hi, Hood appreciated. Here i attached the xml file. I am using the JNC-40M came together with the cnc desktop machine. At the moment the maker cannot support how to solve it. Now stall there cannot do the Ref All Home... The stepping motor seem like ok, when i load the gcode go into mach3, machine did run XYZ axis movemenet according to gcode. However, i couldn't continue it without doing Ref All to Home. And the continue Joy also cannot run properly as well.  :'(
Really hope Hood can gave advice...... Thanks.