Hello Guest it is January 26, 2020, 10:23:17 PM

Author Topic: T Tool change frrd / plunge isue  (Read 2922 times)

0 Members and 1 Guest are viewing this topic.

T Tool change frrd / plunge isue
« on: May 22, 2012, 06:41:22 PM »
Hi this is my first post in this forum.  Have a lot to lern.



Usialy when a for example a command M6 T002 is reached the spindle stops and I change the tool, set the hight and get on with the job.
Unfortunatly I updated mach3 and started using cambam at the same time so dont know which is the problem.
I copyed the Mach3Mill.xml  over and all works well. exept one thing.

I am having a problem then the T (tool change) command in G code (I think)
after changing the tool, setting the hight,and pressing cycle start, Z goes up to +50 DROPPS the feed to 5 then VERY slowly back to Z0 once it gets back to Z0 the feed rate returns back to what ever it was before.

I dont understand why it is dropping to 5 but it is very anoying.

Any advice please?

Thank you

Offline ger21

*
  • *
  •  6,291 6,291
    • View Profile
    • The CNC Woodworker
Re: T Tool change frrd / plunge isue
« Reply #1 on: May 22, 2012, 08:24:42 PM »
Sounds like this is in your g-code.

M6 is the tool change command, btw.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: T Tool change frrd / plunge isue
« Reply #2 on: May 22, 2012, 08:44:19 PM »
Thanks for your reply
Ah sorry yes M6

This is a sample of my codeline number added for explination:-
Code: [Select]

( Made using CamBam - http://www.cambam.co.uk )
( Sleeper V6 Nest 50 All 5/17/2012 6:30:32 PM )
( T0 : 0.0 )
( T1 : 1.0 )
( T103 : 2.9 )
001  G21 G90 G64 G40
002  G0 Z3.0
003  S1000
004  F300.0
005  ( Clean Top )
006  S1000
007  G0 Z3.0
008  G0 X3.0
009  G1 Z-0.1
010  G1 X28.0
010  ( Top Clamp Clean )
011  G0 Z3.0
012  ( T1 : 1.0 )
013 T1 M6
014  M3 S1000
015  G0 X4.0938 Y12.05
016  G1 Z0.0
017  G1 Y11.425 Z-0.0453
018  G3 X4.5938 Y10.925 Z-0.1023 I0.5 J0.0
019  G1 X5.8438 Z-0.193
020  G3 X6.3438 Y11.425 Z-0.25 I0.0 J0.5
021  G1 Y12.05 Z-0.2953
022  G3 X5.8438 Y12.55 Z-0.3523 I-0.5 J0.0
023  G1 X4.5938 Z-0.443
024  G3 X4.0938 Y12.05 Z-0.5 I0.0 J-0.5
025  G1 Y11.425
.
.
.
.

All ok at F300 until it gets to line 013. Z goes to +50 Then it dose the tool change cycle but the feed drops to F5 untill it gets to Z0 when it gets to line 014 the feed goes back to F300.00??????

Any ideas??

Thanks

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: T Tool change frrd / plunge isue
« Reply #3 on: May 23, 2012, 02:53:04 AM »
Likely your M6 macros are doing that.
Hood
Re: T Tool change frrd / plunge isue
« Reply #4 on: May 23, 2012, 09:28:58 AM »
Thanks
How do I open the macro to see what it is doing?

Regards
Anthony

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: T Tool change frrd / plunge isue
« Reply #5 on: May 23, 2012, 11:05:49 AM »
You can use the editor in Mach (from Operator menu its VB Script Editor option) to open the macro and view its contents, there are 2 for mill, m6start.m1s and m6end.m1s. You will find the correct ones in the macro folder of the profile you have loaded, for example it will be in C:\Mach3\Macros\**** where the **** is the name of the profile you are using.
Hood