Hello Guest it is August 12, 2020, 12:19:42 AM

Author Topic: Step pulse / Dir pulse  (Read 6331 times)

0 Members and 1 Guest are viewing this topic.

Step pulse / Dir pulse
« on: February 24, 2012, 05:03:00 AM »
Hola,

Tenemos una Fresadora Optimum y recientemente hemos comprado el Mach3 para dejar de utilizar el programa simple que traía la máquina.
El ejecutar un programa que hacía trabajar los motores lentos hemos visto que uno de los ejes pierde pasos, que el motor va a trompicones. He estado mirando y tocando el la velocidad del kernel y los parámetros Step pulse y Dir pulse, la cosa mejora, pero tengo miedo a que según que velocidades pase lo mismo.
Quisiera saber si hay alguna manera de saber que parámetros he de introducir en esos valores. Dependen del pc, de la controladora de los motores, de los motores...?

Un saludo y gracias.
Rubén.

Offline Algec

*
  •  25 25
    • View Profile
Re: Step pulse / Dir pulse
« Reply #1 on: February 26, 2012, 04:29:39 AM »
El kernel dejalo en lo mas bajo, si lo subes mucho, depende del hardware del pc, puede funcionar mal.
Cuando la tengas bien controlada puedes probar subiendo de paso en paso al siguiente escalon y probar.
Afecta a velocidades añtas d ela maquina.
Quita todo lo que este resiedente en el pc de programas , hasta el antivirus si puedes y vuelve a probar.
Re: Step pulse / Dir pulse
« Reply #2 on: March 04, 2012, 10:01:10 AM »
vete a motor tuning y cambia los parametros de velocidad y aceleracion
si acelera muy rapido a veces tambien pierde pasos

envialo muy lejos  utilizando g0   y luego vuelvelo g01  lento para ver si en el proceso de ir  perde pasos

ves aumentando o reduciendo velocidad hasta asegurarte que no pierde nada

suerte
Re: Step pulse / Dir pulse
« Reply #3 on: March 06, 2012, 03:26:11 AM »
Gracias por los consejos, haré pruebas.

Rubén.
Re: Step pulse / Dir pulse
« Reply #4 on: November 16, 2013, 12:47:54 PM »
lo mas normal es que ese motor a nivel de hardware no este buen configurado. es decir,
si se calienta , va a trompicones o mete mucho ruido y no es un problema mecanico que este interrumpiendo el deslizamiento suave del eje entonces seguramente lo que ocurre es que el driver del motor de pasos no este configurado con una subdivision de pasos alta por ejemplo mas de 128, y lo mas probable tambien es que los amperios seleccionados en el driver no esten seleccionados justo con los amperios que necesita el motor en sus especificaciones.
Asi mismo, si la fuente de alimentacion DC que estamos utilizando no tiene la suficiente intensidad en amperios necesaria segun se haya seleccionado en el driver y las necesidades del motor, entonces seria tambien un problema.
Asi pues, lo primero de todo revisar que el hardware es el adecuado en esos tres elementos, que no hay ningun impedimento mecanico en el eje y que la configuracion que se haga en el driver sea correcta intentando dejar al maximo posible la subdivision en micropasos puesto que esto dara mas suavidad y menos resonancia al motor, con lo que se evitara ruido y calentamiento del mismo.
Si todo eso esta bien entonces luego mira en mach3.
Suerte
Justo