Hello Guest it is December 13, 2019, 04:56:56 PM

Author Topic: Z home goes past 0.0 to +1.0  (Read 13136 times)

0 Members and 1 Guest are viewing this topic.

Offline ttm

*
  •  40 40
  • Learning my first CNC router plasma setup
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #40 on: January 28, 2012, 05:42:28 PM »
I'm with you there TP, appears to be a mix.

I want to say thanks again, i have moved so much further today after getting that fixed, (well maybe not in some of you guy's standards), but I have moved along, it feels good, was actually able to get past my last issue, not sure where i read bout using a marker lightly attached, but that helps, at least I do not have to worry about damaging something

it seems some of you have the same controller Candcnc, so I will ask, how am I going to know if I have loaded the right screens for my setup?  I loaded right from the install file
keep in mind this is a couple year old unit as well
thanks

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #41 on: January 28, 2012, 05:57:11 PM »
EASY , ASK TOM over at CandCNC to make SURE you have loaded the correct plugin and screenset.  There are several different applications on the install disk. With his systems they are highly integrated and you need to run the proper setup per hardware to get the BEST results and fewer suprises.

The good side is they are documented in his product manuals. Most just don't bother to read and study them.

(;-) TP

Offline ttm

*
  •  40 40
  • Learning my first CNC router plasma setup
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #42 on: January 29, 2012, 04:58:42 AM »
EASY , ASK TOM over at CandCNC to make SURE you have loaded the correct plugin and screenset.  There are several different applications on the install disk. With his systems they are highly integrated and you need to run the proper setup per hardware to get the BEST results and fewer suprises.

The good side is they are documented in his product manuals. Most just don't bother to read and study them.


then I have the right screen sets, and I have read his install manual several times now, some of the manual is a bit hard to get and put to use (at least to me it is), or something else is wrong with part of the equipment,
even following it step by step, i have even uninstalled and started over, i bought another computer eliminating any possible port conflict (this one only has one serial and one parallel port), that was not the issue,  as i have the same issues.

right now I would love to see someones pins and ports with the same system i have, but it can not be the new ubobIII from my understanding. 

And, I think my issues tend to be a bit fun as the previous owner had done a couple changes or upgrades to it. Pins and ports are different through some of the versions of hardware if i am understanding tom correctly. the machine does some funny things at times still and the input lights never seem to be what I am told they are supposed to be, right now I want to get it working without the torch setup, if I can do that, get he gantry to move where it is supposed to when it is supposed, get homes firggured out and limits in place, i will at least be making some progress.

 I have found after everyday for the last 3-4 weeks I can not do it without help.  I thought i could get it going, wow was I wrong.
buying a used system, that was pieced together (converted from practicalcnc), that supposedly ONLY not needed setting up parameters was not wise.
I do not even know what servo motors are on this table.  but i do have it running correct length if you manually enter in the mid scree

Offline RICH

*
  • *
  •  7,380 7,380
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #43 on: January 29, 2012, 05:36:07 AM »
Quote
Most just don't bother to read and study them.

Terry,
Maybe we should  start a thread on the subject to explore it some. We live in a world of plug and play, but one must admit that it can be frustrating
when trying to grasp just one subject from what is documented.
An example relating to limit and home switches on documentation:
MANUAL                                                                      PAGE

USING MACH3 MILL                                                       4-8 to 4-11, 5.3,5-17,6-2, 12-1, 1-17
MACH3 CNC CONTROLLER SOFTWARE & INSTALLATION    4-9 to 4-15, 5-5, 5-6
MACH3 TUTORIAL (setting up a 3axis machine)                 11,12,13,14
CALYPSO MANUAL                                                         61
Lets not forget about getting off the limit switches  ( USING MACH3 MILL page 4-10)

ttm,
Above is worth reading and studying to understand. What makes this more difficult is the use of  a different screen set than normaly used  
and requires additional attention and information to get to the problem. You can thank the folks in here for going the extra mile spending
their time to find what they need to address the problem.

Remember that all this is supposed to be fun,

RICH


Offline ttm

*
  •  40 40
  • Learning my first CNC router plasma setup
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #44 on: January 29, 2012, 06:34:11 AM »
Quote
Most just don't bother to read and study them.

ttm,
Above is worth reading and studying to understand. What makes this more difficult is the use of  a different screen set than normaly used  and requires additional attention and information to get to the problem. You can thank the folks in here for going the extra mile spending their time to find what they need to address the problem. Remember that all this is supposed to be fun,
RICH
Rich, did I come across that I didn't REALLY appreciate the help?  I really have said thank you to everyone and I do mean it, heck I would still be trying to figure out why I was going +1.0 past my 0.0 on z if it was not for them posting about the button reference that can only be seen with screen4, I would still looking for for some setting on a screen, never even dawned on me to look into customizing any buttons settings.  Am I being a thorn?  if so I can step back some, I'm darn tootin happy there are folks willing to take their time to help. I really do not think I can do this on my own at this point.

I have looked at the manuals quite a few times, I'm just not getting it I guess. I have read the install manual  and tried to reference it as much as possibly to the mach manual, like I said i have been doing it night and day for weeks now,

again THANK you too everyone that is helping, you have no idea what a difference you have made in just this thread, I really need to get all the settings figured out, what they do, what they mean, and how to implement them, in my head and on the table.

I will look at those links agian, I did put full shots of my screen up and config files on a picsaweb page
just in case someone asks to see one I can send them a link


thank you

Tom
« Last Edit: January 29, 2012, 06:36:35 AM by ttm »

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Z home goes past 0.0 to +1.0
« Reply #45 on: January 29, 2012, 07:53:26 AM »
I did put full shots of my screen up and config files on a picsaweb page
just in case someone asks to see one I can send them a link
Better if you just post em right here Tom. See the Additional Options link below where you type your reply (not quick reply). Just note they need a name not used here before so just precede each filename with your username or something else that makes them likely to be unique.
« Last Edit: January 29, 2012, 07:55:52 AM by stirling »

Offline RICH

*
  • *
  •  7,380 7,380
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #46 on: January 29, 2012, 09:49:40 AM »
did I come across that I didn't REALLY appreciate the help

Not at all Tom ,and  maybe I should have said "we" instead of you ;)

RICH

Offline ttm

*
  •  40 40
  • Learning my first CNC router plasma setup
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #47 on: January 29, 2012, 11:52:21 AM »
did I come across that I didn't REALLY appreciate the help

Not at all Tom ,and  maybe I should have said "we" instead of you ;)

RICH

no worries, just want to be sure people know I DO appreciate the help!

I am about to start on homes, actually setting them up and working on my z axis issue, but I want to know i am talking in the right terms before I start asknig too many quesitons

Im waiting to get a few pieces of stock monday to make my limit brackets a bit differently than they were setup, I'm going to put them on the gantry one for y on the end and one for x in the center of the gantry, and use a stop on each end of those runs to activate the switch,

 but I can start on homes for table and material loading which I think I have an understanding on more today, and hope my plan is a good one.  now on to setting up home configurations, while I try to figure out my other issues


thanks for everything

Offline ttm

*
  •  40 40
  • Learning my first CNC router plasma setup
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #48 on: January 29, 2012, 11:53:43 AM »
I did put full shots of my screen up and config files on a picsaweb page
just in case someone asks to see one I can send them a link
Better if you just post em right here Tom. See the Additional Options link below where you type your reply (not quick reply). Just note they need a name not used here before so just precede each filename with your username or something else that makes them likely to be unique.

ok thanks, I just hate to use a bunch of file space up if there is no need to.  I thought about putting a link to the folder where they are posted

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: Z home goes past 0.0 to +1.0
« Reply #49 on: January 29, 2012, 12:49:48 PM »
HIYA TOM, IF you loaded the correct plugin/screenset from the CANDCNC install program THEN you should have all the correct settings to make it work. The only thing that needs setup is the SLAVE axis for the long axis. And then it should be to select the DIRECTION of movement.

The XML that comes with the install is correct for MOST applications and covers all the assesories inputs such as limits, home,etc for the standard setup of a machine.  

When I get back to the shop I will make a copy of the setup we use.

HIYA RICH, Not the case with the CandCNC stuff it is high documented as TOM created a very integrated package that is NOT like a standard MAch3 installation SO in turn he documented it VERY WELL with LOTS of pictures and diagrams and words.

(;-) TP

« Last Edit: January 29, 2012, 12:53:29 PM by BR549 »