Hello Guest it is September 22, 2019, 12:30:46 AM

Author Topic: Gcode more than 100,000 lines  (Read 4423 times)

0 Members and 1 Guest are viewing this topic.

Gcode more than 100,000 lines
« on: January 25, 2012, 07:21:27 AM »
I have recently purchased "PhotoVCarve" software and started to get into lithophane world !
After some trials, I have started a program generated by the software which is expected to finish in about 5 hours.
I have been checking the machine every 30 to 40 minutes, and found the machine is stopped near to the end  :o!!!!
On the Mach3 screen (I use 2010 screen), red RESET button is blinking.
(at this moment, I didn't check the line number)
I pressed restart button timidly, the reset button turns green.
And press "Cycle Start" button, the machine moves properly until the end  :D
Afterward, I check the program and find the number of Gcode lines is more than 100,000.
Actually the line number starts from N20, and after N999990, next line is N0 as pasted below;
-------------
.
.
N999970X10.887Y99.895Z-0.387
N999980X10.649Y99.656Z-0.413
N999990X10.092Y99.100Z-0.373
N0X1.344Y90.351Z-0.373
N10X1.105Y90.112Z-0.399
N20X0.787Y89.794Z-0.477
N30X0.469Y89.476Z-0.663
N40X0.230Y89.238Z-0.919
.
.
---------
Final line of the files is "N13650M30".

I'm not sure the machine is stopped between N999990 and N0.
It is not a serious trouble, but not good for my heart ....

Is there any limit about number of lines ??

Thanks for any suggestions.
Re: Gcode more than 100,000 lines
« Reply #1 on: January 25, 2012, 07:49:10 AM »
Mach3 has a limit of 10,000,000 lines of Gcode when licensed.
Does the 2010 screen give you a message as to why it stopped ?

If it went into RESET, I doubt that it is related to the line #'s, possibly coincidental that it stopped where it did. And, it probably lost its referenced position.

You can change the PP in the Vectric SW (can in VCP so assume you can in yours also) to increment of 1.
Russ

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Gcode more than 100,000 lines
« Reply #2 on: January 25, 2012, 07:54:49 AM »
Probably the watchdog in Mach but as Russ said the error message would help know what was wrong. Two things I would suggest, disable toolpath view on very large files (settings screen I think) and also disable the watchdog in Mach (General Config page)

Hood
Re: Gcode more than 100,000 lines
« Reply #3 on: January 25, 2012, 08:00:58 AM »
Ahhh...yes. That dang dog !
Might have seen the abrupt line # change as an anomoly ?
Nice catch Hood.

Russ
Re: Gcode more than 100,000 lines
« Reply #4 on: January 25, 2012, 08:25:41 AM »
Thanks gentlemen for your quick posts.

I will check the setup of PVC tomorrow, it is time to sleep in Japan.

By the way, lothophane is very interesting.
The software is priced reasonable, I would say it is unbelievable cheap.

Bon
Re: Gcode more than 100,000 lines
« Reply #5 on: January 25, 2012, 08:37:59 AM »
Interesting indeed ! Vectric is priced right, very stable and has GREAT support !
I'm betting you have seen this :  http://www.machsupport.com/forum/index.php/topic,8762.0.html

Please be sure to post some of your work, we are all eager to see.
Thanks,
Russ
Re: Gcode more than 100,000 lines
« Reply #6 on: January 26, 2012, 02:49:47 AM »
Hood is correct.

I have tested a long program (ca. 110,000 lines) with and without watchdog.
If watchdog is unchecked on the general config, machine runs through without any trouble.

Also I could see an error message "Driver Watchdog Triggered" on the screen if the watchdog is checked.
When my trouble had occurred I was in a panic and could not notice the error message. See attachment.

Thank you all
Bon

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: Gcode more than 100,000 lines
« Reply #7 on: January 26, 2012, 03:22:13 AM »
Good to hear you got it :)
Hood

Offline Jd

*
  •  10 10
    • View Profile
Re: Gcode more than 100,000 lines
« Reply #8 on: January 26, 2012, 01:30:36 PM »
Hello Glad you got it, I had a similar problem  a year ago when I started using PhotoVcarve and Wrapper. Because the time needed for some Lithos was so great I started sharpening my cutters in different configurations and playing with feed rates to cut the time down while maintaining a good cut. As I started getting into 75K and 80K programs my machine would stop around the 60K mark (but only once in awhile like a week apart), the error message was limit switch pressed ( something like that ) or Estop pressed, I know it is some kind of noise problem but after a wire re-sheilded and 1 month of other stuff chasing the noise I have set my debounce in Mach3 to 2 and have cut 30 Litho's with no problem. The problem only occurred when using PhotoVcarve with all the little short moves. Nice program, someday will solve this issue. probably by accident
Re: Gcode more than 100,000 lines
« Reply #9 on: February 23, 2012, 07:20:22 AM »
Hello
I'm also experiencing the same thing .My codes are from 1mil to 2.6 mill long.At the end of the program the steppers would lose position and do some crazy moves. Yesterday I removed the M30 at the end of the program and the program worked fine for first time in weeks I'll try again today.
Dave