Hello Guest it is July 21, 2019, 03:38:00 AM

Author Topic: Gcode more than 100,000 lines  (Read 4388 times)

0 Members and 1 Guest are viewing this topic.

Offline Tweakie.CNC

*
  • *
  •  7,850 7,850
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Gcode more than 100,000 lines
« Reply #10 on: February 23, 2012, 07:31:37 AM »
Dave,

The M30 would make G0 moves so check your motor tuning because you probably have the Velocity / Acceleration set far too high.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Gcode more than 100,000 lines
« Reply #11 on: February 23, 2012, 05:17:10 PM »
Hi Tweakie
I've tried different settings , doesn't seem to matter. I tried emlimating the middle of the code, leaving the first few hundred lines and the last few thousand lines and everything works fine. Seems to only happen with very large files.
Don't understand?
Dave
Re: Gcode more than 100,000 lines
« Reply #12 on: February 24, 2012, 06:32:52 AM »
 Just ran 2 programs overnight both with over 1mill lines, removed M30 and both ran perfect. does anyone understand this?
thanks Dave
Re: Gcode more than 100,000 lines
« Reply #13 on: April 09, 2012, 02:31:44 PM »
I just ran a path with just under a million lines.

Around halfway through I encountered SEVERAL "limit switch activated" errors, even though the switches were clearly not activated. The machine was moving very slowly at the time so I was able to restart from position, but it kept faulting out every few minutes for a total of about ten times, then went on and machined the remainder of the part (another 500,000 lines) without a hitch.

I am aware that noise is often the culprit. I will check and reset the debounce to 2000 unless someone thinks another number is better.

Is there anything else I should change?

I am not getting watchdog errors.

I am using Tempest with its older Mach version. Ethernet smoothstepper plugin v10a. No errors from the ESS that I can tell.

In another part of the path, the X-axis stopped moving completely at one point, though it would jog on the screen. I do not think this was related, but I cannot be sure, because repowering the machine, rehoming and rezeroing fixed the issue. I thought it was a wiring issue, but all wires from the control to the motor showed continuity. It has never done that before.

Thanks,
Karl