Hello Guest it is November 14, 2019, 11:03:20 AM

Author Topic: CV not working  (Read 2860 times)

0 Members and 1 Guest are viewing this topic.

CV not working
« on: December 04, 2011, 03:01:20 PM »
I have a problem with cutting detailed 3D reliefs, in that I can't seem to get mach to do any CV blending of moves- the workpiece I'm currently doing is 2m x 1m and I'm rastering (in the Y axis) a relief 18mm deep, with a 0.35mm stepover.. the code is not far off a million lines long  :o

The machine is acting as if it's in G61 regardless of whether it's in G61 or G64, and whatever the CV settings are at- it does a move then pauses for a fraction of a second, then does the next move. This happens whether the angle between moves is shallow or steep. I've been pulling my hair out trying every combination of motor tuning and mach configs, but I can't get it to do anything different. Even if I could stop it pausing between moves (the pause seems roughly 0.2s), I'd save days on the machining!

normal profiling stuff seems fine. Also, I recently did a bunch of vacuum-forming moulds in MDF that were done in slices and built up to a foot or so thick, and these ran smoothly, but they were less detailed, so I guess my problems have something to do with the smallness of the moves. I can do very fine V bit engraving of serif text on the machine with no problems.

The machine itself is a large woodworking machine, I'm running a PCI Galil 1860 with approx 1kw AC servos in torque mode, and it's capable of 60m rapids (2300ipm), so I'm sure it's not a machine limitation. My problem might possibly be Galil related, but I thought I'd ask in the general forum in case it's a CV issue.

I'm a bit confused about the X-Y, Y-Z etc settings in the general config, they sound like what I'm after, but they have no effect with my code. Is there any detailed documentation on these?

Can anyone tell me whether mach actually does CV when the main axes of motion are X-Z or Y-Z?

Thanks for any info

Offline BR549

*
  •  6,916 6,916
    • View Profile
Re: CV not working
« Reply #1 on: December 04, 2011, 03:24:46 PM »
3d machining reliefs  with micro detail is NOT one of MACH3s strong features. The micro segmented Gcode causes problems with Mach being able to keep up and provide smooth machining.

IF you can reduce the total NODE count(micro moves) on the Gcode it will help a great deal.

Sometimes that stall is just teh machine doing a LOT of micro moves that do not contain much movement. Mach is processing a ton of lines but the results in not much actual movement.

Where do you have the look ahead set to?  200 lines seems to work well here. MORE may work better in your case.

Just a thought, (;-) TP

« Last Edit: December 04, 2011, 03:27:50 PM by BR549 »
Re: CV not working
« Reply #2 on: December 04, 2011, 03:41:48 PM »
hi BR549,

I did try doing a toolpath with a more generous tolerance, but the loss of detail, even viewed on screen, was unacceptable for the job.

When I initially started using this machine for relief work, I was having problems with the gantry shuddering, I worked out that if I allowed a bit of tolerance in the CAM toolpath generation to reduce the number of moves, it sorted that out, so what you suggest is spot on, but I can't take it any further than I have without visible changes.

I've had lookahead set to everything from 10 to 1000, no difference, apart from the slower response of feed hold etc. I have it back at 200 now.

thanks for the suggestions

by the way, the line segments aren't ridiculously tiny, the code is mostly telling the Y to move between 1 and 3mm, with a corresponding Z move of anything from 0 to around 12mm (although mostly the Z moves are 0-3mm)
« Last Edit: December 04, 2011, 03:44:03 PM by steve_p »

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: CV not working
« Reply #3 on: December 04, 2011, 04:12:08 PM »
Turn off all the CV options, and then try it. CV Feedrate, CV Distance, and everything on the General Config page.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: CV not working
« Reply #4 on: December 04, 2011, 04:50:14 PM »
thanks gerry, tried that (actually that's how it was originally) and it runs no different

do you know anything about the XY, YZ, XZ plane options in the general config?
Re: CV not working
« Reply #5 on: January 30, 2012, 03:40:48 PM »
just as a follow-up, I did discover something that might be significant- I re-ran small sections of this program to re-cut some areas that had problems, and they ran much better. I think that the length of the program was causing Mach to run the code worse- the machine was pausing for perhaps 0.25s in every second when running the large program.  I don't know how Mach handles the gcode in memory, whether it loads sections from one part of memory are to another as required or whatever, but it definitely seems on my machine to run differently when the program is huge (>1,000,000 lines). As I said, I'm running a PCI Galil without the parallel port driver installed, so Mach isn't having to spend time doing that side of things. It's on a new 3.2Ghz XP machine with nothing on it but mach and the galil software.

Anyone else noticed the program length having an effect on the machining?

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: CV not working
« Reply #6 on: January 30, 2012, 04:21:47 PM »
Try turning off the toolpath display. It's a must when running large programs on the parallel port. NOT sure if it effects the Galil or not??
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html