Hello Guest it is July 08, 2020, 06:42:45 AM

Author Topic: Homing and Reference all not happening  (Read 5030 times)

0 Members and 1 Guest are viewing this topic.

Offline Lou

*
  •  23 23
    • View Profile
Homing and Reference all not happening
« on: November 30, 2011, 06:37:45 AM »
Hello,

I finally got the jogging problem solved, Thanks to all for your help.
I'm now trying to set the machine up so that I can zero the DRO'S when I toggle to machine  mode,
however it will not zero when I try. when I  jog to the centre of the table on the display mode and try to reference all, again nothing happens.

This I'm not able to do for some reason!! I also find that when I load the now famous Road runner G-Code and I actually
run it the machine, and seems to go through its paces just fine, however at the conclusion it does not return back to the home position.
The z axis stays in the lowered position as if it were going to continue to engrave, I have to manually jog this z Axis back up to the home position.
I believe I have set things up okay!! however not 100% sure. Can some one out there in CNC land offer some advise or clues to what I might be missing or doing
wrong.

My thanks to all in advance for your continued help, I am very new at this and going through a learning process.

Lou

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Homing and Reference all not happening
« Reply #1 on: November 30, 2011, 08:14:10 AM »
Post your xml file and I'll have a look.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline ger21

*
  • *
  •  6,282 6,282
    • View Profile
    • The CNC Woodworker
Re: Homing and Reference all not happening
« Reply #2 on: November 30, 2011, 10:30:19 AM »
Make sure Auto Zero is selected in Config > Homing Limits.

I don't have the roadrunner file here, but the machine won't return to home unless the g-code tells it to, and I'm guessing the roadrunner code doesn't do that.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Lou

*
  •  23 23
    • View Profile
Re: Homing and Reference all not happening
« Reply #3 on: December 02, 2011, 03:14:10 AM »
lou's xml's

Offline Lou

*
  •  23 23
    • View Profile
Re: Homing and Reference all not happening
« Reply #4 on: December 02, 2011, 03:15:22 AM »
Hi Guys,
Hope this info will assist with this issue.

Lou

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Homing and Reference all not happening
« Reply #5 on: December 02, 2011, 04:12:43 PM »
Lou, there is no file attached.  If it is the default name you may have to rename it so you can attach it.  The forum can only have one file of any given name so name it something unique.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Lou

*
  •  23 23
    • View Profile
Re: Homing and Reference all not happening
« Reply #6 on: December 02, 2011, 10:13:52 PM »
Hi Brett,

Sorry I thought I had attached the file.
Hopefully I have done it correct this time round.

Lou

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Homing and Reference all not happening
« Reply #7 on: December 03, 2011, 04:27:43 AM »
IYour xml seems fine for RefAll zeroing the DROs in Machine coords, so not sure what your problem is. Can you explain exactly what you are doing, which buttons you press and when and what you see and what you think you should see?


The last line of  code in the roadrunner tells it to go to X0 Y0 Z0  so thats what it will do. That is not zero in machine coords but rather offset coords.

Hood

Offline Lou

*
  •  23 23
    • View Profile
Re: Homing and Reference all not happening
« Reply #8 on: December 04, 2011, 01:56:35 AM »
Hello Hood,

Okay, I will try to explain step by step the following procedure from the beginning, I start Mach3.

1/   I zero my DRO's

2/   Next, I load the G-Code for the Road Runner,
Road Runner appears on the right of screen dialogue box showing the design.
and a written message on top left hand corner of dialogue box "TOOL:0"

3/  I click display mode button- once I do this the only thing that changes
on the screen is the words "TABLE DISPLAY" appears.

4/ I then click on regen tool path, this shows me the table out line and the
Road Runner is very small on the left bottom corner. ALL OKAY SO FAR.
I can zoom in to get a larger view- That's also okay.

5/  Next, I jog to the centre of the table to set up the job in that position,
or location on the table. X axis shows DRO at 183.0067 - Y axis at 301.4575
and Z axis at 0.000.

6/  I then regen the tool path again, and it shows my job in the centre of the table,
display mode still active. At this stage of proceedings my Road Runner appears as a small dot
with the two purple axis lines intersecting at the appropriate location.

7/  I then click on REF ALL button the X,Y,Z Buttons turn green, I don't get any movement by the axis lines
and the DRO's do NOT move either.

When I look at the Tutorial from Artsoft it shows movement on the axis lines and the DRO'S, I guess what I'm
trying to do is home the machine.

I have also put the Road Runner through it's paces, and all seems to be okay. EXCEPT at the end of the run
the Z axis remains down on the job. I think the z axis motor should home back to the top. should it not!!!!!!!!!

I don't believe that I have homed my machine at all as yet !!, should the three axis return to the bottom
left hand corner of the table once the job has been completed?

So much to learn, with your help I'm sure that i will conquer this, It might take me time though.

Regards,

Lou

 

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Homing and Reference all not happening
« Reply #9 on: December 04, 2011, 03:24:20 AM »
Lou, the first thing you want to do is home the machine.  Since you have no limit switches set up where ever it is at when you hit the Ref all Home button is where it considers home position (machine coord. 0,0,0)  If you want to move where the work is located, jog to that position and zero your work coord. dros.  The zero x ,y, z buttons beside each dro.  This sets your work coord. zeros.  The roadrunner file is written so that work zero is at the bottom left corner.  It will allways be there no matter the difference in your work and machine zeros.  What the the difference in work and machine zeros will do is position your work on the table.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!