Hello Guest it is July 18, 2019, 10:25:37 PM

Author Topic: Config Fonts Doesn't Appear to Work  (Read 14289 times)

0 Members and 1 Guest are viewing this topic.

Hood

*
Re: Config Fonts Doesn't Appear to Work
« Reply #20 on: December 17, 2006, 08:05:55 PM »
like I have said many times before, you must lead a sheltered life if you class me as hero material, ask Mark he will put you straight ;)

Hood

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Config Fonts Doesn't Appear to Work
« Reply #21 on: December 17, 2006, 08:30:25 PM »
Hi Guys:

  (Hood, you kill me..  :) , you didnt need to drop moderator status to say that, hell I woudl have..

 In repsonce to the oringal question, MAch3 is NOT a normal windows program. Try changing the size of
the edi tboxes in a normal windows program. Yes, yes.. I should have removed the font size question, but thats a canned
routine for allowing font size, so i was too time stressed to get around to it.. I put my time as i can to the most valuable things ,
tiny details like that are insignifigant, so Ill get to that when I can.

   Anyone that thinks Mach3 shoudl operate like a "Normal " windows program is not thinking deeply enough, Mach3 runs windows,
not the other way around, and this imposes certain contraints on its operation,  Someday, Ill kill that entry abouit size, it was only added at all
for one person who wanted to use a cryilc font.. But thats the way it is, that user needed it, I had time, so I added it..  :)

  Anyway, I mainly wanted to kick in for Hoods sake, keep up the good work, youre a permanent moderator in my view.... And welcome to be reupped to
that status at any time, I owe you way way more than one..anytime you need anything, just yell..

Art

Offline SimonD

*
  •  143 143
    • View Profile
Re: Config Fonts Doesn't Appear to Work
« Reply #22 on: December 18, 2006, 03:19:54 AM »
You guys really are touchy! All I asked was a simple question.
Instead of being told it is a bug, work around it. I get jumped upon.

I write software too so know how easy it is for bugs to get in I also know all about allocating time. However I will not slag off my potential customers in a public forum.

I don't care if the software is Free or $160 price should have no reflection on quality.

It is a sad world when people cannot express an opinion.
Merry Christmas

Hood

*
Re: Config Fonts Doesn't Appear to Work
« Reply #23 on: December 18, 2006, 03:33:10 AM »
 


It is a sad world when people cannot express an opinion.
Merry Christmas
It was nothing to do with Artsoft, so dont go down that road, that is exactly why I resigned from mod before I expressed my PERSONAL opinion.
 Why do you have to turn up the font size? I have an 18" TFT, have it at the same res as you and have no problem reading the fonts at standard size?

Offline ART

*
  • *
  •  1,696 1,696
  • Tough as soggy paper.
    • View Profile
Re: Config Fonts Doesn't Appear to Work
« Reply #24 on: December 18, 2006, 07:37:29 AM »
Hi:

  I do appologise for any hard feeling, email is a terrible mechanism to transfer feelings or ideas,
sometimes the way something is worded can trigger someone into feleling picked upon, (from both sides).
You original question had overtones of "Surely your screwing up.." written over it when I read it, and trust me,
normally, I would take such things with a grain of salt, but we all have our days. :) , Im willing to bet youve
spat at your wife on occasion for what she thought was a simple question. So if Ive offended you, for that
I appologise, it was really all intended as more "off the cuff" type of replying..
   and DO have a Merry Christmas.. :)

Art

Offline SimonD

*
  •  143 143
    • View Profile
Re: Config Fonts Doesn't Appear to Work
« Reply #25 on: December 18, 2006, 03:24:26 PM »
Why do you have to turn up the font size? I have an 18" TFT, have it at the same res as you and have no problem reading the fonts at standard size?

The reason is one of personal preference and comfort.  I spend 8-10 hours staring at a very high resolution CAD station all day long. By the time I get home I find that my eyes are quite tired and so I find it more comfortable to use a slightly higher resolution for text.  Changing the font size in the Themes menu does not change the font sizes in most applications, the only way to get them larger is to change the global settings which is what I do.

  I do apologise for any hard feeling, email is a terrible mechanism to transfer feelings or ideas,
sometimes the way something is worded can trigger someone into feleling picked upon, (from both sides).
You original question had overtones of "Surely your screwing up.." written over it when I read it, and trust me,
normally, I would take such things with a grain of salt, but we all have our days. :) , Im willing to bet youve
spat at your wife on occasion for what she thought was a simple question. So if Ive offended you, for that
I appologise, it was really all intended as more "off the cuff" type of replying..
   and DO have a Merry Christmas.. :)

Email is a terrible medium as intination is completely lacking. I did try very hard with the original post to not make it not sound like a complaint, which is why I entitled it "Doesn't Appear to Work" and ended it with "Am I missing something??"

For me the biggest issue was that the Config Font Dialog looked like it was offering to change both the font face and the font size, however this was not happening.

The first 2 replies appeared me to miss the point I was trying to get across which meant I had not explained it properly.

My subsequent reply of "The picture I posted is as it appears "OUT OF THE BOX" Surely this is not right?" was not meant as a criticism of the software, more a statement that I assumed the view displayed on my PC was not as you intended the software to look.

Things then went downhill as I got more frustrated at trying to explain the problem I was experiencing...
It wasn't until your explanation that the Font dialog is only supposed to change the Font Face that it became clear what was happening. Perhaps a simple line of text in the dialog or a change in the dialog title would have prevented the confusion. In fact I doubt I would have posted at all if I knew it wasn't supposed to change the font size.

Oh well. Hopefully water under the bridge.
The CNC hardware hasn't arrived yet as I have only just finished converting the Mill to work Digital Readout using the YADRO Digital Caliper Interface. (Writing my own Windows based DRO software)
Ultimately I would like to have the YADRO interface populate the Mach3 DRO's for visual confirmation of where the actual table is located. I realise that Mach3 will not use the DRO's for feedback.
Currently running my software concurrently does not seem to have an adverse effect on the performance of the Mach3 DriverTest but I will have to see.

Best Regards and No Hard Feeling I hope.
Simon

Offline Chaoticone

*
  • *
  •  5,524 5,524
  • Precision Chaos
    • View Profile
Re: Config Fonts Doesn't Appear to Work
« Reply #26 on: December 18, 2006, 03:30:53 PM »
 :)
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Hood

*
Re: Config Fonts Doesn't Appear to Work
« Reply #27 on: December 18, 2006, 03:37:20 PM »
OK reason I asked regarding having to increase the font size is I was wondering if you would notice the slight degradation if you reduced the screen resolution. I know fonts can take on a slightly fuzzy appearance but with the latest tft's I think this is minimal. Even the 6yr old IBMs I have here reducing the screen res to 1024 x 768 still comes up with sharp fonts and images.
Hood

Hood

*
Re: Config Fonts Doesn't Appear to Work
« Reply #28 on: December 18, 2006, 03:40:55 PM »
Another thought is if you are using XP you could set up another user account and have the screen res to suit Mach, then it would just be a case of switching users if you wanted to go from your normal use to having a play with Mach.
Hood

Hood

*
Re: Config Fonts Doesn't Appear to Work
« Reply #29 on: December 18, 2006, 04:16:47 PM »
What kind of output does your digital caliper put out? if its TTL you may be able to hook them up to Mach to give you readouts in Mach.
Hood