Hello Guest it is October 21, 2021, 02:00:37 PM

Author Topic: Setting Steps Per Unit in Mach3  (Read 19488 times)

0 Members and 1 Guest are viewing this topic.

Re: Setting Steps Per Unit in Mach3
« Reply #10 on: July 18, 2011, 06:22:49 PM »
is the sound of the motors constant or varying, like a grumbling sound
Re: Setting Steps Per Unit in Mach3
« Reply #11 on: July 18, 2011, 06:35:49 PM »
The Sound it fairly constant. I would say that a grumbling sound was not far off to be honest.

I have tried different velocity and acceleration settings. The acceleration I have set from quite slow were I could hear the motor speeding up and slowing down then to the max acceleration I try to keep is max speed in 0.1s. Changing the velocity doesnt seem to do anything as I seem to be capped at a relatively low speed. I can make it go slower in  the MDI but not faster.

The Drivers are QJ5045 2-Phase Microstepping Motor Drivers. I have attached the data sheet that I was sent.

The switches are currently set to 8 microsteps, Full Current, and the current choice being 4.2A

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setting Steps Per Unit in Mach3
« Reply #12 on: July 18, 2011, 06:43:22 PM »
I have used the big brothers of these drives and they are quite good, not quite as good as Geckos in my opinion but not far behind. Make sure you have the microstepping set right as the manuals can often be misleading, for example mine had the settings for Step/Dir and CW/CCW round the wrong way.
Also increase your pulse width on Motor Tuning to 3 or 4 and see if that helps.
Hood
Re: Setting Steps Per Unit in Mach3
« Reply #13 on: July 18, 2011, 06:59:54 PM »
The only part I have touched on the drivers is the switches for micro stepping and current. I bought the control unit as a complete ready to go unit along with the steppers. Attached is a photo of the inside of the controller unit. I cant same I`m overly impressed with the quality so far but thats another story and I just want to get the thing working now.
I have asked the guy the same questions but he is a little slow to respond and he has been sorting other problems I had like incorrect cables. Maybe I should check all the wiring to the driver.....

I noticed on the drawing for the wiring of the stepper motor the wires are labelled A and A (with a bar over the top) and on the controller they are A- and A+ is it important which one is which?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setting Steps Per Unit in Mach3
« Reply #14 on: July 18, 2011, 07:04:28 PM »
A and A+ are the same and A with - over the top is the same as A-.

Hood
Re: Setting Steps Per Unit in Mach3
« Reply #15 on: July 18, 2011, 07:08:59 PM »
Does it matter which way around the cables are connected? I noticed on my unit that the guy has not been consistant with the A and B wiring.

i.e A+ going to either A or A with the bar over?

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setting Steps Per Unit in Mach3
« Reply #16 on: July 18, 2011, 07:48:13 PM »
It may or may not, as long as the wiring is consistent on a drive it wont really matter but best really having it as per wiring diag.

Just double check the dip switches are set correct for the microstepping as it does sound as if they might be wrong but could also be the wiring if the coils in the motor are connected wrong I suppose.
Been a long time since I messed with steppers so a bit out of touch with the wiring.
Hood
Re: Setting Steps Per Unit in Mach3
« Reply #17 on: July 19, 2011, 03:26:48 PM »
Today I tried it all on a different PC but its still the same.

I have checked the driver and the micro steps are set to 8 based on the table they print on the case. I tried lowering the speed and the acceleration and they did as expected but I`m still capped at this slow max travel of about 60mm/min.

I have attached a short video I took with my phone so you can hear the Y axis stepper motor in action.

The only thing I can find wrong in the control unit is that pin 25 on my breakout board is not used and in the diagram supplied with the unit pin 25 should be logic ground. Does anyone know if this would make a difference?

Thanks

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setting Steps Per Unit in Mach3
« Reply #18 on: July 19, 2011, 04:31:01 PM »
Flip the switches to the opposite way and see if its any better or worse.
Hard to tell from the vid, doesnt sound right but its so slow it may be.
Wont matter about 25 not being connected as long as the other Gnds are.
Hood
Re: Setting Steps Per Unit in Mach3
« Reply #19 on: July 20, 2011, 05:39:40 PM »
All sorted now! :)

I was having a senior moment and read the 0 as off instead of on when setting the switches on my drivers. So after setting all of them correctly all is working well. :)