Hello Guest it is September 23, 2019, 12:22:55 AM

Author Topic: 4th axis problem  (Read 1909 times)

0 Members and 1 Guest are viewing this topic.

4th axis problem
« on: July 05, 2011, 02:05:15 PM »
Hello

I have set up my 4th axis mechanically and all seems well BUT I have output gcode from a cad / cam system profiling the shape of a propeller cone. in the z axis there is one profile and all the rest are on top of this profile there is no 3d view I have ran it off line and the A axis is rotating but the 3d profile is not there. I have rebuilt my systems over the last year and the last time I out put this code it worked. Is there a setting in mach I should be aware of.. Any help appreciated.

Bob
Re: 4th axis problem
« Reply #1 on: July 05, 2011, 03:27:55 PM »
Hi Bob,

Go to the configure toolpaths menu, there is a tick box that says something like "show A axis rotations"

It will then show the 3d toolpath - and its flipin amazing to see the tool follow the path and the rotate in real time.

ATB
Derek
You can "chop it off" but can't "chop it on"
Re: 4th axis problem
« Reply #2 on: July 07, 2011, 04:57:11 PM »
Hello, I have a similar problem but cannot figure out what is wrong. I've just finished building the 4th axis and all seems to be functioning as it should. After having designed (in Aspire with wrapped axis) a stepped cylinder (with 2 different diameters) and put some letters to engrave on each diameter. When previewing the cutting paths in Aspire all seem to look as intended but when importing into Mach3, the areas where the engraving is suppose to go are being replaced with an engraved belt all the way along the diameter (as can be seen in the attachment). when simulating in Mach3 it seems that the governing axis is the A axis as it is continually turning about it's axis and ignoring the Z axis position. I've tried going through both Mach3 and Aspire settings for the 10th time with the hope of finding something but to no avail. Does anyone have any idea what may be the cause.
Thanks

Marting
Re: 4th axis problem
« Reply #3 on: July 07, 2011, 04:59:23 PM »
Sorry forgot to include the picture.