Hello Guest it is July 14, 2020, 06:22:01 PM

Author Topic: Is backlash compensation broken?  (Read 7684 times)

0 Members and 1 Guest are viewing this topic.

Is backlash compensation broken?
« on: July 04, 2011, 10:08:01 AM »
I recently completed a Little Machine Shop X2 type mill CNC mill and have the latest Mach3 v3.043.022 installed.  I have for sake of discussion .005" backlash entered into the X-axis.  If I jog to the left, and then jog to the right, my first reverse direction will actually jog a little more the the left.  The next jog to the right will then kick in the compensation.

In the HSM forum, someone suggested v3.042.040 which I installed.  It at least moves the right direction on the first reversal, but the full backlash comp does not kick in until the second jog.

Am I wrong to expect the first reverse jog to command the stepper to rotate the full backlash amount plus the current jog amount?  I have backlash comp set to the default 60% max speed.

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Re: Is backlash compensation broken?
« Reply #1 on: July 04, 2011, 04:34:32 PM »
Backlash is implemented when a change in direction takes place.
You should initially remove any backlash by jogging a short distance in one direction before reversing the direction.
I don't remember anything wrong with BC in V3.043.022.
RICH
Re: Is backlash compensation broken?
« Reply #2 on: July 04, 2011, 05:07:12 PM »
Backlash is implemented when a change in direction takes place.
You should initially remove any backlash by jogging a short distance in one direction before reversing the direction.
I don't remember anything wrong with BC in V3.043.022.
RICH

That is what I thought should happen.  During the CNC build class, a couple of ArtSoft gents stopped by.  I showed one of them the odd behavior, and he was scratching his head on this behavior as well.  At the time, I didn't notice that the first jog in the opposite direction was actually advancing a table a bit in the wrong direction, as I was concentrating on the obvious sound that is made when the backlack comp. sets in.  I was very evident that the BL comp was happening on the second jog.

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Re: Is backlash compensation broken?
« Reply #3 on: July 05, 2011, 07:22:16 PM »
I am using version 3.042.033 and know for a fact that there is no problem in that version here.
Backlash settings that were used:
- 50% of max speed
- 0.005 Shuttle Acceleration
- Debounce interval 500

Can you post your xml file?
Do you have any break out boards, using the PP, etc?

You may want to try a slower percent, Shuttle Acceleration of say .010 of even .05 so you can watch the backlash get implemented at a snails pace.
Testing my memory as i don't use BC anymore...... ;)

RICH

 
Re: Is backlash compensation broken?
« Reply #4 on: July 05, 2011, 09:07:48 PM »
Hi Rich,
Thanks for the response.  I'll pull the xml file from the laptop.  
I don't have a shuttle, simply using the cursor keys on my keyboard to jog.  Does the shuttle setting affect that as well?
I'm not sure how to post it, so I put it on my server:
http://www.compufoil.com/HiTorque.xml
I am running the smooth stepper on my system.

I'll download and try out 3.042.033 as well.
« Last Edit: July 05, 2011, 09:16:37 PM by AiR_GuNNeR »

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Re: Is backlash compensation broken?
« Reply #5 on: July 06, 2011, 06:53:35 AM »
Check that you have the latest SS plug in. Don't know how well BC works with the SS since it was implemented so maybe someone else can remark about it's BC functionality.
You may also want to visit  the WARP9 site since there are threads on BC  and the SS.

To post your xml fle give it a unique name like AIRGUN.XML and use then click the Additional Options which allows you to select the file from your pc to upload.

RICH
 
Re: Is backlash compensation broken?
« Reply #6 on: July 06, 2011, 07:33:13 AM »
Hi Have HiTorque.xml attached for you.
Re: Is backlash compensation broken?
« Reply #7 on: July 06, 2011, 07:43:53 AM »
Thanks for the hint on the Warp9 site.  This is from their downloads site of the latest development version.  It looks like the smooth stepper is the problem...so...the next question I have is can Mach3 be configured to use both the parallel port as well as the smooth stepper?  Parallel port for the motion control, and SS for the additional IP?

From Warp9 site:
"- Backlash compensation has been added. This version works great as long as you do not enter moves that are shorter than the amount of backlash you have. In particular, you will notice this if you use MDI or Step Jogs and you inch towards something and then back off. I am working on a version that will make that work properly. "

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Re: Is backlash compensation broken?
« Reply #8 on: July 06, 2011, 09:56:29 PM »
Quote
Parallel port for the motion control, and SS for the additional IP?
Don't know for sure but don't think so.

Quote
From Warp9 site:
Glad to see that Greg got something implemented for BC.
I sovled the BC problem by eliminating it from my machines and it was worth the effort.

RICH
Re: Is backlash compensation broken?
« Reply #9 on: August 11, 2011, 12:07:35 AM »
I can not get backlash comp to work either
no matter what I put in for a number nothing changes.