Hello Guest it is February 25, 2021, 06:29:06 AM

Author Topic: problems with spindle run on my CNC  (Read 3684 times)

0 Members and 1 Guest are viewing this topic.

Offline dinko

*
  •  12 12
    • View Profile
    • Bavant.eu
problems with spindle run on my CNC
« on: June 11, 2011, 12:51:05 PM »
Greetings !!

I have poblems with Connections/Setup on mach 3 with spindle:

i have 4 ports on LPT conroler that i can on/off my electric things.

RELAY1= P1
RELAY2= P16
Pump= P17

Spindle =P14
Spindle speed =P14* i thing i need to regulte extra electronics...

so i need help to setup my MACH3 to on/off my spindle and where to connect

THANKS!!


p.s. : sorry about my english

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: problems with spindle run on my CNC
« Reply #1 on: June 11, 2011, 01:05:50 PM »
How are you controlling your spindle speed? What kind of spindle/drive is it?
Hood

Offline dinko

*
  •  12 12
    • View Profile
    • Bavant.eu
Re: problems with spindle run on my CNC
« Reply #2 on: June 11, 2011, 01:20:25 PM »
I have controled speed witout electronics... i need just off/on.. so i need only when start maching to turn on spindel and when its done spindel off. no need to regulate speed

TNX

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: problems with spindle run on my CNC
« Reply #3 on: June 11, 2011, 01:34:30 PM »
Ok so you only need one output to turn On/Off the spindle via a relay.
Hood

Offline dinko

*
  •  12 12
    • View Profile
    • Bavant.eu
Re: problems with spindle run on my CNC
« Reply #4 on: June 11, 2011, 02:04:23 PM »
i setup on:

Config>Ports and pins
Output signals:

on output#1 :Chacked | 1 | 14 | active


but doesent work nothing

or if i must work on something other setup ??

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: problems with spindle run on my CNC
« Reply #5 on: June 11, 2011, 02:11:19 PM »
Config, Ports and Pins, Spindle Setup and uncheck "Disable Spindle Relays" and enter 1 for M3. see pic.
Hood

Offline dinko

*
  •  12 12
    • View Profile
    • Bavant.eu
Re: problems with spindle run on my CNC
« Reply #6 on: June 11, 2011, 02:18:58 PM »
i have this seting like you show and i change settings like i saw on video on mach3

output#1 : cahcek | 1 | 1 | active and still dont work...

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: problems with spindle run on my CNC
« Reply #7 on: June 11, 2011, 02:19:59 PM »
Can you attach your xml please and I will see if I can find a problem.
Hood

Offline dinko

*
  •  12 12
    • View Profile
    • Bavant.eu
Re: problems with spindle run on my CNC
« Reply #8 on: June 11, 2011, 02:36:33 PM »
I hope it will work

tnx

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: problems with spindle run on my CNC
« Reply #9 on: June 11, 2011, 02:39:34 PM »
Sent you a PM
Hood