Hello Guest it is June 24, 2019, 08:16:44 AM

Author Topic: Travel diestance does not match command  (Read 2878 times)

0 Members and 1 Guest are viewing this topic.

Travel diestance does not match command
« on: June 02, 2011, 05:18:57 PM »
I am working on a small converted lathe and am turning only wood till I get this figure out.  I break fewer tools that way!

What I have done:
Went into the motor configuration and set my step rate to match the actual travel.  When, I jog my x axis 1 inch, it moves 1 inch (measured with micrometer) and the display on mach shows that my x has moved one inch.

I have run the turning wizard to just turn the OD of a part from .70 to .60 (love the wizards btw.)  I get everything lined up and zeroed.  I run the gcode that the wizard has generatred and then measure the part when finished.  It actually is moving 2x the distance it is supposed to.  It measures .50 when I finished my run instead of the .60 that it was supposed to measure.

The Z axis has the same stepper motor and same pitch lead screw and the controller is set the same and it does move the proper distance when running the program.

This is probably a simple fix but I have been reading and looking for 2 days and have not solved it yet.  Can someone lead me in the correct direction?
Re: Travel diestance does not match command
« Reply #1 on: June 02, 2011, 06:01:37 PM »
Btw, Mach shows that it is at .60 when it is finished.
Re: Travel diestance does not match command
« Reply #2 on: June 02, 2011, 09:53:12 PM »
Gosh I thought this would be an easy answer.  Guess I'll have to go to plan b and just double the number of steps per inch and not pay any attention to what the motor set up is like.

Offline BR549

*
  •  6,873 6,873
    • View Profile
Re: Travel diestance does not match command
« Reply #3 on: June 02, 2011, 10:16:14 PM »
that is not your answer(;-) IF your axis are moving the corrct  distance,  then it is a setup problem OR Gcode problem

Are you in diameter mode or radius mode ??? DID you setup on the part diameter and set it correctly
« Last Edit: June 02, 2011, 10:18:54 PM by BR549 »
Re: Travel diestance does not match command
« Reply #4 on: June 02, 2011, 10:25:22 PM »
This is normal, when the tool move 0.100 in the X direction, it will remove 0.200 because you're working with radius but material is remove in diameter.

The tool remove material from front and back of the part, that's why you end up with 0.500 in diameter.

You could just divide by 2 the setting in the motor tuning or set your Cam program to work with diameter.


Jeff
Re: Travel diestance does not match command
« Reply #5 on: June 02, 2011, 11:52:40 PM »
I think the solution is the diameter / radius mode.  That is the toggle I have been looking for but have not found.  Please. please, please tell me where it is. 

I was running the wizard that is built in to mach3.  The turning wizard is pretty simple.  Enter the starting x value and the desired x finish value.  Guess i could mess that up but don't think I did. 

Offline RICH

*
  • *
  •  7,338 7,338
    • View Profile
Re: Travel diestance does not match command
« Reply #6 on: June 03, 2011, 05:31:45 AM »
Sonic,
You can set the mode in CONFIG>PORTS & PINS>TURN OPTIONS.
The mode choosen is personal preference, but, some of the wizards don't work correctly in both modes.
It is wise to draw in, CAM in, and set the config / post processor  for the same mode. Mixing modes is asking for trouble.
Be carefull when using software as to which post processor is selected and you may even want to add a comment line in
the Gcode as to which mode was used to generate the code.

RICH
Re: Travel diestance does not match command
« Reply #7 on: June 03, 2011, 07:01:07 AM »
Thanks.  I had looked in just about every section of the config except ports and pins.  I thought there was no way it would be there.

Thanks again.  Will be trying it later today.