Hello Guest it is November 23, 2020, 12:04:12 PM

Author Topic: Automatic Tool Change bug when using Mach 3.43.35  (Read 1969 times)

0 Members and 1 Guest are viewing this topic.

Automatic Tool Change bug when using Mach 3.43.35
« on: May 01, 2011, 02:32:42 PM »
Posted this on the Mach Yahoo site.
I was using Mach 3.43.22 with David Bagby's MSM enhancement for Mach 3 and
having no trouble doing ATC tool changes. I upgraded to Mach 3.43.35 because of
the Estop script bug in Mach 3.43.22. Now I can't do any ATC tool changes. All I
get is a message in the status bar saying Tool Change Complete. I made sure that
ATC tool change was enabled on the Config screen. Still no ATC tool change. I
went back to Mach 3.43.22. ATC tool changes work again. Sorry for posting bug
here but didn't know where to do it on the Mach form or web site.

Eric

Re: Automatic Tool Change bug when using Mach 3.43.35
« Reply #1 on: May 04, 2011, 12:00:36 PM »
Hi all,
FYI - This issue turned out to be a combination of things.

1) The results of Mach's GetCurrentTool() call changed with Mach 3.43.35
(compared to mach 3.43.22 lock down).
There was a bug in 3.43.22 where the results of the call lagged 1 tool change
behind the contents of OEMDRO 824. With 3.43.35 they now match.

2) The change in the result from the mach call exposed a bug in MSM that in turn
impacted ATC script handling. I've fixed MSM to match the mach change and ATC
use under MSM is now working again with mach revisions >= 3.43.35. MSM users
with ATCs will want to update to MSM v1.1.3 to get the fix.

Dave
Author of the MachStdMill Extensions for Mach3
www.CalypsoVentures.com