Hello Guest it is April 15, 2024, 09:20:07 AM

Author Topic: Struggling with RS485 & Teco 7300CV  (Read 12790 times)

0 Members and 1 Guest are viewing this topic.

Struggling with RS485 & Teco 7300CV
« on: March 19, 2011, 02:42:06 AM »
I've read & re-read the articles .. I've tried copying other peoples settings & brains .. but I just can't seem to get modbus controlling the VFD.
I will admit I'm new to this, although I do have considerable computer experience. 
I'm using Serial w/ plug-in and a RS232 to RS485 converter straight out of the serial port. 
I can communicate with the VFD using the setup software that came with it.  I can read & write to output holding registers from the modbus test window but all I get are timeouts & VFD faults when trying to deal with coils.
I have a working brain (everything lights up as expected) 
I would gladly start from scratch if someone can help me set this thing working.

Attached is the VFD function code & memory map manual for those who know what their looking at.
Re: Struggling with RS485 & Teco 7300CV
« Reply #1 on: March 19, 2011, 07:40:13 AM »
Hi,

Upload an image of the Mach3 Modbus setup screen. That i probably where the problem is.

Also you need to write a Brain to set the speed from the Mach3 speed variable.

Cheers,

Peter.
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Struggling with RS485 & Teco 7300CV
« Reply #2 on: March 19, 2011, 10:17:58 AM »
Thanks Peter ..

I'm actually awaiting the arrival of a Homann ModIO which is in transit as we speak ..
I've been trying to get things set up with the 232 to 485 converter in the mean time ..

Screens are below ..
Re: Struggling with RS485 & Teco 7300CV
« Reply #3 on: March 24, 2011, 07:35:28 PM »
Hello GD:

Have you seen the free download " RS232 Analyzer.msi " program at www.commfront.com ?

I just downloaded it to play/practice learning more about my own Modbus setup. It sounds like a pretty powerful tool.

Regards,
John
   
Re: Struggling with RS485 & Teco 7300CV
« Reply #4 on: March 24, 2011, 10:18:04 PM »
Had not seen that one yet but won't do me much good now ..
Talking to supplier about this drive & wound up sending it back to them today ..
We'll see what happens in a week or two when it comes back.

Thanks!
Re: Struggling with RS485 & Teco 7300CV
« Reply #5 on: March 25, 2011, 01:32:54 AM »
Hello again, G.D.

Well, I did install the "free demo" Analyzer software, and tried it on my RS232 conn going to my Cubloc Modbus. When my Modbus is talking to Mach3, and the Feed override is going up and down as it should, and the different buttons on the screen are working on my panel through Modus, the software says it cannot connect, because the Port is "already Open." I don't know if you have to use a different serial cable or what. Mine is a standard off the shelf male/female DB9 cable, on Com 1, at 19200 baud, 8-N-1.  So, I might give them an email question to find out how I can "see" my Serial data. Meanwhile, I watched a bunch of short videos they (Commfront) have regarding this software. It is pretty amazing what it can read (Binary, Ascii, Decimal, Octal), analyze, print Rx and Tx in different colors, in real time, and capture all to a file. The free download has some limitations compared to what the $79.00 software does, but it will let you "see" what is going back and forth. While you are waiting, give a look at the Commfront videos. They are pretty impressive. Looks to me like a very powerful tool. Now that I have played with it a little bit, I can see the value of dual monitors, as suggested in another post by Poppa Bear, and he is the total "Modbus Guru" as things go with Mach3.

John
 
Re: Struggling with RS485 & Teco 7300CV
« Reply #6 on: March 29, 2011, 03:41:04 PM »
Greetings G.D.

As a follow-up to my last reply; I did get an answer from Commfront regarding using their RS232 Analyzer software. My connection to Modbus is a single, M/F DB9, straight through connector, on Serial Comm 1. My Modbus connection is working fine, no problems.

When I ran the demo Commfront software, the program said" Cannot connect, Port already connected."

The Commfront reply to my various questions told me, in order to run their software program, I need to get another cable, and connect to a second computer, Laptop, or whatever is available. The Analyzer software needs to run on it's own Serial port.

The cable required is their part number: CBL-FULL-1A.
It has (4) DB9 connectors, (2) M/F pairs , and somehow connected appropriately in the middle.

To use the setup:

(1) Plug in one DB9 pair into the computer RS232 comm port running Mach3, and the other end of that line to the Modbus connector.

(2) Plug in the next pair to the same computer running Mach3 (need to use a USB to RS232 adapter if no extra Comm port available),
and the other end to a second computer. The software Analyzer runs on this computer. If it is a laptop with no RS232 connector, you need to get another USB to RS232 adapter.

Now, after assigning the correct ports in the Analyzer software program, all the data passing between the Mach3 program, and the Modbus, will show up on the second computer monitor, in the Analyzer screen, send and receive (in separate colors for readability) . You can send pre-written scripts, or codes; save all data to a log file, ...... etc.

//////////////

At this time, I do not need such a analysis setup, but as I get further into using Modbus, and working with the capabilities in Mach3, I certainly would consider the small expense well worth it. We all end up spending quite a lot of time getting our projects running, and an extra 150.00 is not that great an expense in the overall picture. I already have one USB to RS232 converter made by Parallax. I got it from "Solarbiotics", and it works great on my second DB9 port on the Cubloc 32-M board. I think it was about $22.00.  It is for the second Cubloc serial port, for downloading ladder logic/Basic programs into the CB280 module.

Regards,

John


 




 
Re: Struggling with RS485 & Teco 7300CV
« Reply #7 on: April 13, 2011, 07:53:42 PM »
OK, ModIO came in .. is set up & communicating with Mach 3 without any apparent issues.

As previously mentioned .. Teco 7300CV drive had to be sent back to FactoryMation for service & they decided to credit me for that one & told me to order a new one as a replacement .. OK Fine, except they are out of stock on my drive now .. so I ordered a Hitachi SJ200 instead which should be here by end of week.  

I believe I have a working setup in Mach's Serial Modbus setup & I'm pretty sure I have a working Brain.  I can lite output LED's on the ModIO using  M3, M4, M7, M8 .. and I can get the spindle rpm dro in Mach to show the spindle speed I'm entering into MDI

I do have some questions for Peter if he should see this post ..

#1 Do I use terminals 2&3 to connect RS485 to the drive? and do I need a ground wire between the ModIO & the Drive also?  
#2 Do I need to switch any jumpers on the ModIO to use it as a 232 to 485 converter? (reading the manual I supposed they only needed to be switched if RS485 was being used to communicate to the ModIO .. is that correct?)
#3 Do I need to create another ModIO setup (called perhaps ModIOVFD) for the drive in the ModIO plugin?  If so, can you give me instructions on what to enable & disable there?  If no 2nd setup is required through the plugin, how do I establish the VFD as node 2 on the modbus chain?

Thanks in advance for your help


Re: Struggling with RS485 & Teco 7300CV
« Reply #8 on: April 19, 2011, 02:16:43 AM »
Hitachi SJ200 showed up today .. but I'm still stuck.
Can't get any communication with the VFD through the ModIO .. (or with a 232 to 485 converter either)
I've checked settings on the drive & in Mach over & over again .. tried every combination of outputs 1,2,3,4 that I could think of for the 485 cable into the drive. 

NO LUCK ..

Any help would be very much appreciated!

Thanks
Re: Struggling with RS485 & Teco 7300CV
« Reply #9 on: April 19, 2011, 02:39:00 AM »
Here's the Modbus config & brain I have in Mach just in case anyone sees an error I'm not seeing ...