Hello Guest it is August 22, 2019, 08:06:25 AM

Author Topic: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows  (Read 5846 times)

0 Members and 1 Guest are viewing this topic.

Offline sn96

*
  •  53 53
    • View Profile
Hello guys,

Last night I installed my CNC upgrade for my 5400 Sherline mill. After spending a few hours figuring out how to get the motors to run because I didn’t know what I was doing, I spent another several hours tiring to get the homing and soft limits to work properly, my fault there too. I got everything working good except one more thing. Why when I have 5" travel in the Y-axis does the DRO show double digit numbers? right now I have a value of 35.00 for the Y-axis even though that’s not the full length of travel, but for purpose of understanding I set it to 35.00, when I thought it should be 5.00". Its like the motors are moving 0.1" instead of 1.0".

Do I need to calibrate the motors or to tell mach3 what an inch is?
________________
Mike

Sherline 5400 with Sherline steppers
Visual Mill 6.0 Standard
Mach3
Windows XP

Offline RICH

*
  • *
  •  7,351 7,351
    • View Profile
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #1 on: March 05, 2011, 09:13:00 AM »
1. First make sure that you have Mach configured for the units  you will be using ( mm or inches ).
2. Then set the steps per unit in motor tunning ( i think the screws are 20 TPI, so steps per unit is 200 x 20 x 10US=40000 if your drive is set for 10
    microsteps. Assuming the stepper is directly connected to the screw.
3. Now go to the settings tab and use the axis calibration to check the steps per unit over a long travel.
4. Now check for backlash.

Don't know what kind of drives you have and you may want to post that info.

RICH

Offline sn96

*
  •  53 53
    • View Profile
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #2 on: March 05, 2011, 03:54:22 PM »
I have the standard Sherline driver box and motors. I actually got pretty close to making the motors work considering I didn't really know what I was doing   . at this point everything has been guess work. The formula you posted will do me some good. I cut my first tool path using the "shapes" program that comes with mach3. The road runner program is to large for my milling table.

I spent several hours in the garage this morning learning about zeroing and motor calibration. I was not aware about using the formula you posted and I wish I would have read your post before I started, but I only have one computer box at the moment, and I had to use it out in the garage with no internet connection.

One thing I noticed when jogging close to the soft limits, it takes forever for it to actually reach 0. whe it gets close it slows down and makes a whining noise like EEEEeeeeeeeerrrrrrrrrr - r  - r - r - r ................r. Is there any way to speed up those last few "R's"  lol.


Thanks for the help! This is getting fun.


« Last Edit: March 05, 2011, 04:01:20 PM by sn96 »
________________
Mike

Sherline 5400 with Sherline steppers
Visual Mill 6.0 Standard
Mach3
Windows XP

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #3 on: March 05, 2011, 03:59:54 PM »
The soft limits have a slow zone, you set that to the amount it needs to slow from full rapid speed without  hitting the limits.
You would be best to get your steps per unit sorted first though as everything depends on them being right :)
Hood

Offline sn96

*
  •  53 53
    • View Profile
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #4 on: March 05, 2011, 09:12:42 PM »
In the motor tuning, it only shows max 5us so in my case it sould be 20000. Right? I don't see where you got 10us?
________________
Mike

Sherline 5400 with Sherline steppers
Visual Mill 6.0 Standard
Mach3
Windows XP

Online Tweakie.CNC

*
  • *
  •  7,885 7,885
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #5 on: March 06, 2011, 04:01:11 AM »
Quote
The road runner program is to large for my milling table.

Mike,

On the main screen alongside the X and Y DRO's are the Scale DRO's (currently set to +1.0000) entering 0.5 and pressing return here will scale that axis to half size (and so on). You can scale anything up or down in size as well as turning things inside out.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline RICH

*
  • *
  •  7,351 7,351
    • View Profile
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #6 on: March 06, 2011, 06:25:23 AM »
Mike,
I will assume that you have at least taken a look at the Mach 3 Manual.

Quote
In the motor tuning, it only shows max 5us so in my case it sould be 20000. Right? I don't see where you got 10us?

The microstepping is set on the driver which is inside your controller box. It may be something different than 10 or provide you other options like 1/4, 1/8,1/16
so look at your info on the controller. I just used 10 us as an example and if it's a different value it will change the steps per unit.

Additionaly the 5us max in motor tuning is something different, namely Step Pulse time and you need to see what is recomended.
Also, in Ports and Pins there is a selection for "Sherline 1/2 pulse mode " which you may need to check.

Post your contoller info and we will have a look to see what is correct.

RICH
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #7 on: March 06, 2011, 07:10:13 AM »
it may help, if you tell us how many steps per unit you have it set too on each axis.

Offline RICH

*
  • *
  •  7,351 7,351
    • View Profile
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #8 on: March 06, 2011, 10:45:08 AM »
If Mike uses the axis calibration feature he need not even calculate them, but first, he needs to provide controller info so Mach is set up correctly.
RICH
 

Offline sn96

*
  •  53 53
    • View Profile
Re: Sherline mill 5400 - Motors not moving the didstance Mach3 DRO shows
« Reply #9 on: March 06, 2011, 02:05:49 PM »
If Mike uses the axis calibration feature he need not even calculate them, but first, he needs to provide controller info so Mach is set up correctly.
RICH
 

The cnc upgrade kit didn't come with any info on the driver box, only safety info. The manual that came with my mill has a section on the driver box and the only thing it says is the "steps per pulse should be 15us"
________________
Mike

Sherline 5400 with Sherline steppers
Visual Mill 6.0 Standard
Mach3
Windows XP