Hello Guest it is June 18, 2019, 01:47:53 PM

Author Topic: Importing G code  (Read 4316 times)

0 Members and 1 Guest are viewing this topic.

Offline rickw

*
  •  110 110
    • View Profile
Importing G code
« on: February 06, 2011, 07:27:06 PM »
I have a question, which I have tried to figure out on my own but I can't. After importing code into Mach, the image is way out of soft limits set on my table. How can I move the image closer to my set limits within working distance to zero and begin cutting? I have tried everything. What I had to do, which worked, was move the Cam file image closer to a 0,0 coordinate and re-entered it into Mach, and it was within the soft limits but what a pain. Is there a way to move the code image around in Mach? I would have to think there is a way..........

Any advice would be appreciated.
Re: Importing G code
« Reply #1 on: February 06, 2011, 07:33:15 PM »
Have you set your work offsets

Offline rickw

*
  •  110 110
    • View Profile
Re: Importing G code
« Reply #2 on: February 06, 2011, 07:35:41 PM »
I set a work offset and zeroed the DRO. Then I regenerated the window but it did not move within the soft limit settings. What am I doing wrong?
Re: Importing G code
« Reply #3 on: February 06, 2011, 07:44:56 PM »
Is the job bigger than your table movement

Offline rickw

*
  •  110 110
    • View Profile
Re: Importing G code
« Reply #4 on: February 06, 2011, 07:53:34 PM »
No, its mounted to the table, well within limits. I know I am doing something wrong so I will go through some steps to my failure. I imported the code and the image is way off the right and you cant even see it unless you zoom out. I moved the tool (spindle) to a spot on the piece I want to cut and zeroed the DRO. Then clicked on regen and the image is still off to the right, way out of soft limit setting of the table. Not sure what to do.
Re: Importing G code
« Reply #5 on: February 06, 2011, 08:01:12 PM »
i get the feeling that you've not set the work offsets correctly. Try this, home your machine and make sure the dro's are set to machine coords, which should read zeros Then jog the tool to the start point of the job and go to the offset screen and and enter the dro values in the current work offset dros and save then at the bottom of the page. If you go back to the main screen and press the machine coords button it should read zeros, and whaen you press it again it goes back to the distance you're from the mome switches. Then try the code.

Offline rickw

*
  •  110 110
    • View Profile
Re: Importing G code
« Reply #6 on: February 06, 2011, 08:23:58 PM »
I did that already. Currently, I click on Machine coord's and it shows how far I am from the home switch. Then I click off and the DRO reads all zeros. Then I click regen tool path and the image is way off to the right, out of the window, unless I zoom out. This is still G54 Fixture 1. Something is messed up!!

Offline ger21

*
  • *
  •  6,261 6,261
    • View Profile
    • The CNC Woodworker
Re: Importing G code
« Reply #7 on: February 06, 2011, 08:27:56 PM »
Sounds like you're creating the code in the CAM software outside of the machine limits.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline rickw

*
  •  110 110
    • View Profile
Re: Importing G code
« Reply #8 on: February 06, 2011, 08:33:39 PM »
That could be true because I had to delete some parts in CamBam and then I entered the remaining part I needed in Mach as code. How could I verify that this is the case? 

Offline rickw

*
  •  110 110
    • View Profile
Re: Importing G code
« Reply #9 on: February 06, 2011, 08:44:21 PM »
I guess I should ask this question then. I draft parts in AutoCad and import them in CamBam to transfer them to code. If the part will fit on the router table, is it possible to have it in a spot on the CamBam that will not import correctly in Mach? I ask this because I know the part is well within limits of my table. But it may not have been at a 0,0 coordinate in the Cam software. Could this be a problem? Earlier today, I had the same problem but moved the drawing closer to 0,0 within the Cam software. Then when I imported the code, it was within the soft limit settings. I can't believe that one would have to do this every time. I am still pretty green at CNC ing.