Hello Guest it is November 13, 2019, 09:21:30 AM

Author Topic: When limit switches are triggered, mach3 lags for a few seconds  (Read 2653 times)

0 Members and 1 Guest are viewing this topic.

When limit switches are triggered, mach3 lags for a few seconds
« on: January 30, 2011, 02:22:50 PM »
Hi,

So I have a problem with mach3 and limit switches.

I have setup the limit switches, and they worked perfectly. As soon as the switch was triggerd, the axis stopped. As well as the ref home worked good.
However, when I installed a RS485-to-usb-converter to control my spindle by mach3, this is no longer working;

Now when the limit switches are triggered, I have to wait 2-3 seconds before mach3 notices and stops the axis. This is NO good for any application.
This happens whether the spindle is turned on or not. This doesn't matter. The spindle control workes perfectly without lag.

So the setup: The limit switches are connected to Gecko540 BOB. The X-switches to input 1, Y to input 2, and Z to input 3, and everything is setup correctly in Mach3.
The computer is a Intel dual core 2.2Ghz with a pretty new motherboard (dont remember the specs), and Ive got 2 gigs of ram. So this is way more than enough on the hardware part.

Also: Everything else works as it should. Milling out parts after G-code, jogging, and all other parts of it. Except for when I press my external E-stop switch, mach3 lags 2-3 seconds here aswell. This E-stop is directly connected to the gecko, so the gecko stops all the axes momentarily.


Anyone have an idea of what my problem is? Do you need more info on my setup?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: When limit switches are triggered, mach3 lags for a few seconds
« Reply #1 on: January 30, 2011, 02:46:40 PM »
Do you have a high value set for Debounce Interval on the General Config page?
Hood
Re: When limit switches are triggered, mach3 lags for a few seconds
« Reply #2 on: January 30, 2011, 05:22:28 PM »
Baaah!!

That may so be true, as I did all sorts of stuff to try to solve another problem I had (which I solved).

Ill check tomorrow and let you know again.

Thanks alot!
Re: When limit switches are triggered, mach3 lags for a few seconds
« Reply #3 on: February 01, 2011, 06:32:07 AM »
So I've checked it out, and you're absolutly correct about the debounce settings!

I turned it back to 0, and now everything works perfectly! :)


Thanks Hood!  ;)

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: When limit switches are triggered, mach3 lags for a few seconds
« Reply #4 on: February 01, 2011, 03:41:50 PM »
Thats good as its the only thing I could think of that would do that so if it wasnt I wouldnt have had an answer ;D
Hood