Hello Guest it is October 19, 2019, 04:07:50 AM

Author Topic: Need Help in Port configuaration  (Read 2033 times)

0 Members and 1 Guest are viewing this topic.

Offline Shivu

*
  •  18 18
    • View Profile
Need Help in Port configuaration
« on: January 28, 2011, 08:01:32 AM »
Hi All,

I am using MACH3 to control a two axis lath.

I don't have a inbuilt Parellel port in the PC so i am using a PCI card for the Parellel port.

When i installed this PCI card and connected to the external hard ware all the outputs are giving 4.8V irrespective of the O/P in MACH3 On or off. also all the input are high irrespective of the inputs.

The port number the parallel port is LPT1, and in the Ports and Pins i have configured the port#1 address as 0x378.

Can anyone help me to solve this problem.

Shivu

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Need Help in Port configuaration
« Reply #1 on: January 28, 2011, 08:18:56 AM »
Go to windows device manager and look at your PCI cards address, it is on its resources tab, then enter that for Port 1 in Ports and Pins in Mach.

Hood

Offline Shivu

*
  •  18 18
    • View Profile
Re: Need Help in Port configuaration
« Reply #2 on: January 28, 2011, 08:29:37 AM »
HI Hood,

Thanks for the suggestion, i have tried the same but still the problem exists.

I tried changing the port address to 2 and 3 but didn't worked.

Any other solution?

Shivu

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Need Help in Port configuaration
« Reply #3 on: January 28, 2011, 08:42:20 AM »
Im not sure if you are understanding so here is what you need to do. Go to the control panel in Windows to find the ports address. Click on Start button in Windows then go to Control Panel then System then Hardware then finally Device manager. The look down the list and expand the Ports and choose your PCI port, might be LPT1 or 2 or...... double click it then go to the resources tab and look at the address, see the screenshot below, it will be the first 4 digits, not the same as them but... well you get the idea. Once you have the address you go to Ports and Pins in Mach and enter that value for Port1

Hood