Hello Guest it is September 21, 2019, 06:17:54 PM

Author Topic: edit button script will not save in R3.042.040  (Read 13617 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #10 on: January 15, 2011, 12:01:52 PM »
The steps are,
open Mach,
choose Edit Button Scripts (from Operator menu)
 Click button you wish to edit,
 edit the script,
preferably use the save from file menu and close editor.

Is that what you are doing?
 If it is then I dont know why its not working for you as I am trying that here with the version you mention and using keygrabber.
If you attach your xml and .set I will test here with them and see if I get the problem.
But if you are doing it in a different manner then its not going to work.
Hood

Offline miket

*
  •  18 18
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #11 on: January 15, 2011, 01:13:15 PM »
Hi Hood,
Yes. I  edit the button in Mach3 using edit button script and it works if i dont use
the keygrabber. The files in question are attached.

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #12 on: January 15, 2011, 02:06:29 PM »
Can you also attach your .grab file that you have for the Keygrabber.
Hood

Offline miket

*
  •  18 18
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #13 on: January 15, 2011, 02:31:11 PM »
Here is the grab file

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #14 on: January 15, 2011, 02:54:21 PM »
Afraid I cant replicate your problem here, it works fine for me, each time I edit shut down and restart and look again and the script has stuck.

Hood

Offline miket

*
  •  18 18
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #15 on: January 15, 2011, 03:39:05 PM »
Thanks for you help Hood. I will now clean the Mach3 installation and start again and see what happens.

Offline miket

*
  •  18 18
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #16 on: January 16, 2011, 12:32:49 PM »
Today I uninstalled Mach3 and setup Windows XP to be as lean as possible.
Ran mach3.exe /p myprofile and the edit button script works. The macro file is saved
and the myprofile.set file is updated.

But again, running keygrabber.exe /p myprofile does not save the file and *.set file is not
updated. Even saving the *.set file within Mach3 and reopening the macro does
not work.

I then tried another computer running XP home edition. I get the same result!!!!!

Unfortunately I will just have to use mach3 without the keygrabber,

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #17 on: January 16, 2011, 12:59:24 PM »
That is very strange indeed, works fine for me with your xml, screenset and .grab file, cant understand why its not for you.
Dont think there are different versions of keygrabber but maybe there are, one I have is version 4.0.0.11

Hood

Offline miket

*
  •  18 18
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #18 on: January 16, 2011, 01:10:37 PM »
My keygrabber is the same version.

Just to remind you what I do:

run mach3 using keygrabber, edit button script, modify file, save, close.
Check *.set file for date change (NO) , edit button script again and no change to file.

All this works fine if I dont use keygrabber.

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: edit button script will not save in R3.042.040
« Reply #19 on: January 16, 2011, 01:24:24 PM »
Well I dont check in any way, open Mach via keybrabber, edit button, close, then can edit button scripts again and it shows it changed or can exit Mach and restart and again it has the changes.
How are you checking the changes when you say "Check *.set file for date change"
Maybe try missing that step out and see if it works.
Hood