Hello Guest it is November 11, 2019, 06:17:40 PM

Author Topic: Unwanted Router Starts...Kinda scary!  (Read 2415 times)

0 Members and 1 Guest are viewing this topic.

Unwanted Router Starts...Kinda scary!
« on: November 16, 2010, 08:37:43 PM »
My cnc board is an inexpensive china import from ebay. For the most part it performs well but there is one thing that is a little alarming. The router will turn on and off during PC boot. The router is connected to a solid state relay. That SSR is fed a trigger signal through a small relay on the CNC control board. The small relay is permanently wired to PIN 17 (Output#1 in Mach) of the parallel port.

When I first power up the PC the router is OFF. Right after POST I hear the small relay click on and then the router spins up. As soon as I get to the windows XP login screen the router shuts off. From that point forward it will only come on when commanded.

This router has scared me more than once and I dread to think what would have happened if I had my hand in the area of the router when I began to boot the PC.

Any ideas? Thank in advance.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Unwanted Router Starts...Kinda scary!
« Reply #1 on: November 16, 2010, 09:05:27 PM »
First, you should NEVER have any power applied to the machine until Mach3 is running.

But, if you want to live dangerously, at least get a board with a charge pump, which should prevent this from happening.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Tweakie.CNC

*
  • *
  •  7,984 7,984
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Unwanted Router Starts...Kinda scary!
« Reply #2 on: November 17, 2010, 07:43:20 AM »
As Gerry has said, you should always follow the correct procedure when starting up and shutting down your machine. Always start Mach first.
I have, in the past, seen videos posted of machine runaways (axis as well as spindle) caused by a PC reboot.
Take care.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline ASC

*
  •  59 59
    • View Profile
    • Automation Systems
Re: Unwanted Router Starts...Kinda scary!
« Reply #3 on: November 22, 2010, 01:27:22 PM »
Agreeing with what the other guys said, powering up the machine before mach is running is asking for trouble.  The port flips and flops all over the place on startup.  A stepper motor pulsing a few steps or a spindle starting up at random is one thing, but imagine a linear motor capable of travelling 5 meters per second with 500 pounds of thrust backing it up randomly deciding to blow through your limit switches, hard stops, workshop wall, etc...

The charge pump can protect against this, as well as requiring an external "enable" signal to motor and spindle drivers, but the safest bet is to always have mach running first!
Mr. Creosote