Hello Guest it is December 02, 2021, 01:52:10 PM

Author Topic: Setup question  (Read 3354 times)

0 Members and 1 Guest are viewing this topic.

Setup question
« on: November 14, 2010, 08:50:29 PM »
Hi,

When I use Mach3Mill, I can jog my motors fine. However, when I switch to Plasma with seemingly the same setup, I can't get the motors to budge. Any Ideas?

Thanks

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setup question
« Reply #1 on: November 15, 2010, 02:14:03 AM »
Correct port address?
Do the DROs move in Mach when you jog?
Hood
Re: Setup question
« Reply #2 on: November 15, 2010, 06:56:37 AM »
The port address is the same as are the pin assignments. The estop is not setup now so is set as active low which is the same as it was set in the mill version. The DRO values do change while jogging while the stepper motor just sits there. It is energized however as it will not turn by hand.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setup question
« Reply #3 on: November 15, 2010, 07:02:04 AM »
Can you attach both the mill and plasma xmls please

Hood
Re: Setup question
« Reply #4 on: November 15, 2010, 06:11:51 PM »
Here are the mill and plasma profiles.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setup question
« Reply #5 on: November 15, 2010, 06:25:14 PM »
First thing I see is you have MaxCL enabled in the plasma, that is likely your problem, disable and see if it works. You will get it from Config menu then Ports and Pins and its top right of the main page.
Hood
Re: Setup question
« Reply #6 on: November 15, 2010, 06:27:58 PM »
Thanks for the quick reply. I'll give it a try tomorrow at work and let you know.

-Jim

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setup question
« Reply #7 on: November 15, 2010, 06:29:08 PM »
Also you have the plasma set as metric for native units and mill is imperial, you will need to change that once its running and also your Y axis is different steps per unit in the plasma from mill.
Hood
Re: Setup question
« Reply #8 on: November 16, 2010, 11:13:57 AM »
Turning off MaxCL did the trick.

Thanks, Jim

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Setup question
« Reply #9 on: November 16, 2010, 11:30:45 AM »
:)

Hood