Hello Guest it is July 20, 2019, 06:10:11 AM

Author Topic: Installation craching my computer  (Read 11333 times)

0 Members and 1 Guest are viewing this topic.

Offline BxBx

*
  •  15 15
    • View Profile
Re: Installation craching my computer
« Reply #20 on: November 08, 2010, 02:55:21 AM »
Mike - point well taken, although I don't remember this computer ever locking on me like that (except crashing on Mach 3 install, of course  :))
I appreciate the link too, but as I'm in Thailand it's not much good for me.  Computers are a little more expensive here, but the other perks make up for that  ;))
But that switch idea is a good one.  Actually, my monitor has two ports (I use DVI now, VGA is open) so maybe I won't even need a switch (have to consult the manual).
In any case, if I can get some input on how to get those positioning commands from USB/serial port, I'm still contemplating that.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Installation craching my computer
« Reply #21 on: November 08, 2010, 03:00:57 AM »
You would need to write a plugin.
Hood

Offline BxBx

*
  •  15 15
    • View Profile
Re: Installation craching my computer
« Reply #22 on: November 08, 2010, 06:23:07 AM »
Thanks Hood. 
That’s a bummer.  I wouldn’t mind putting time into writing pulsing code for the TI chip, but I don’t have time to be writing code for positioning commands from Mach 3.  There isn’t any standard one (e.g. for servos) except that LPT steps generator (which obviously doesn’t work on all PCs)?

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Installation craching my computer
« Reply #23 on: November 08, 2010, 08:01:35 AM »
Each motion controller has its own plugin, example SS, DSPMC, Galil, K-Flop and Ajax all have plugins  but all are specific to each piece of hardware and have been written as such. So if you dont want to go with one of them and dont want to go with the PP then its write your own plugin for the hardware you wish to use.
Hood

Offline BxBx

*
  •  15 15
    • View Profile
Re: Installation craching my computer
« Reply #24 on: November 08, 2010, 11:17:27 AM »
Yes, Hood.  They all have their own plugin because no one has disclosed his (well, G100 did a not so good one a few years back, which as I understand was then improved by SS).  I can understand that guys wanting to sell >$1000 HW don't want to make a plugin that could be used also by someone else.  But there are many <$10 MCUs that can be programmed for the pulsing task and if someone would make a standard positioning output plugin, guys that know how to do the code for a particular MCU would not have to worry also about messing with Mach3.  Although I would be willing to do the code for TMS320F28335 (as I can use it for other things later), I can make no money of selling $99 TI HW and no incentive in putting time into Mach3 plugin.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Installation craching my computer
« Reply #25 on: November 08, 2010, 11:33:26 AM »
There is a Mach SDK for plugins, but not being a programmer I dont have a clue how easy it is, suspect its not just a simple matter of writing a few lines though  ;)
Hood

Offline BxBx

*
  •  15 15
    • View Profile
Re: Installation craching my computer
« Reply #26 on: November 08, 2010, 07:54:18 PM »
Yes, I saw it.  For me it would definitely involve some learning curve I don't have time to get on.  The TI chip is a different matter.   ArtSoft should have done it a long ago (in my view), or someone interested in making $20 of selling such standard output plugin might be interested.

Offline bs

*
  •  3 3
    • View Profile
Re: Installation craching my computer
« Reply #27 on: November 18, 2010, 10:36:38 PM »
Hi Hood ,and BXBX

It seem to be a problem in thailand , I 've tried using mach 3 under windows xp 1..3 and get the exact problems  further more I noticed that wind xp does not give any signals to the parrarlle port. I 'm running for 4years now with win2000 and win 2003 and it works instandly but can't get any movement under xp.
The divice manager gives a fault at mach pulsing engine , would nice to finally get it working with Xp. The computer is used with other programs ,no problems

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Installation craching my computer
« Reply #28 on: November 19, 2010, 02:24:36 AM »
Try setting your regional settings to UK or USA or some other western country.

Hood
« Last Edit: November 19, 2010, 02:26:37 AM by Hood »

Offline bs

*
  •  3 3
    • View Profile
Re: Installation craching my computer
« Reply #29 on: November 19, 2010, 07:52:50 AM »
Hi Hood
tried that already , doesn't change anything.
Any system under win 2000 or 2003 works fine ,it must be the configuration of win xp any computer I tried in past with xp doesn't communicate .
As I don't have installation disks of xp , I can't do the proper optimisation for xp ( uploading wth F5 I believe )