Hello Guest it is July 04, 2022, 11:20:44 AM

Author Topic: Background Image  (Read 6662 times)

0 Members and 1 Guest are viewing this topic.

Background Image
« on: October 17, 2010, 09:09:30 PM »
I can't seem to get my background image (or any image for that matter) to display when I load my screen into Mach3. Is there something I am missing? I've tried saving just an image and nothing else as my set file and still nothing. The only thing that shows are the background color and the items I have added in Machscreen. I am using 64 bit Win 7 if that makes any difference.

I can't seem to get screen 4 to work with this OS either. Should it?

Thanks

Ryan
Re: Background Image
« Reply #1 on: October 18, 2010, 03:04:10 AM »
Hi Ryan,

using MachScreen try swapping the layer. Be sure you are in multiselect mode (most right icon in toolbar showing "M") Select the background image keep the ctrl button down and select the in Mach3 hidden element. Hit right mouse button to open the context menu. Select swap layer. In the dialog box you see the selected items. Hit Swap button. If this doesn't help, please send me you set-file.


Klaus
The brain isn't a soap, it doesn't shrink when used.
Re: Background Image
« Reply #2 on: October 18, 2010, 08:46:26 PM »
Klaus,

Thanks for your quick response. A couple questions. What is the hidden element you are referring to? Does it matter where these images are stored ie do they need to be in the Mach 3 bitmap folder? I tried copying them to "my bitmap" folder that I put in the Mach 3's main folder and that didn't help either.

Attached is a very simple screen with only three DRO's and three image buttons. When I load this screen in Mach3 all I can see are the DRO's. No buttons.

I tried to swap the layers but with multiple items I'm not sure I am getting that done correctly.

By the way, thanks so much for all your work on this program, it looks wonderful. I'm sure it will prove to be great once I figure out what I'm doing!

Ryan
Re: Background Image
« Reply #3 on: October 19, 2010, 03:38:26 AM »
Hi Ryan,

I thought a bitmap is not shown, because it is covered(hidden) by another larger bitmap.
You can place your bitmaps in any folder starting from  folder Mach3\Bitmaps. In the set-file you've sent, your bitmaps must be in Mach3\Bitmaps(Where Mach3 is assumed to be the the install folder).
Are the bitmaps shown OK in MachScreen?
Make sure there is no "user defined image path" specified in Options->Settings Generic progr settings.  If the bitmaps still don't show up, please use "export project" in menu File and send me those files. In the export dialog you can create a folder where the files are placed.


Klaus
The brain isn't a soap, it doesn't shrink when used.
Re: Background Image
« Reply #4 on: October 19, 2010, 08:26:06 PM »
Thanks Klaus! It works now. Not sure what exactly fixed the problem but I put my bitmaps in the mach 3 mill bitmaps folder and deleted the user defined image path that I had in the setup screen. Thanks again!

Ryan
Re: Background Image
« Reply #5 on: October 20, 2010, 01:25:30 AM »
Hi Ryan,

I think what it made work was removing the "user defined image path". You can put your bitmaps in a separate folder, as long as it is "under" the Mach3-Installpath\Bitmaps, e.g. c:\Mach3\Bitmaps\MyBitmaps


Klaus
« Last Edit: October 20, 2010, 03:17:52 AM by Klaus1311 »
The brain isn't a soap, it doesn't shrink when used.