Hello Guest it is November 21, 2019, 01:21:12 PM

Author Topic: Solidcam 2006 Rev10 to mach2-mach3 post pro  (Read 99136 times)

0 Members and 1 Guest are viewing this topic.

Offline dba

*
  •  1 1
    • View Profile
Solidcam 2006 Rev10 to mach2-mach3 post pro
« on: October 29, 2006, 11:30:49 AM »
Here's the post pro i made for solidcam 2006.

U just have to unzip the 2 files in ur /solidcam/GPPtool folder.

Feel free to comment it.

DB.

ynneb

*
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #1 on: October 29, 2006, 04:32:23 PM »
Thanks for that, I will upload it to the new post pro section. http://www.machsupport.com/cam.htm
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #2 on: June 15, 2007, 04:42:53 AM »
IMPORTANT! I just started with SolidCAM and found out that the M3 and M4 have been switched around in this post processor! already broke a tool because of this.
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #3 on: July 01, 2007, 07:15:07 AM »
dba,

Thank you for this post pro. I am just starting with mach3 and SolidCam and I must say, it works great! I am trying to let my milling machine work in 4 axes (X-Y-Z-4_axis_around_X) but it seems the 4_axis_around_X does not work... I think this is becouse the mach3 post-pro does not have the 4th axis implemented. Is it possible for me to do something like that ?

@ debos,
What doe you meen by that the M3 and M4 are switched around and is this possible to solve easily?

Greatings from Holland!
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #4 on: July 01, 2007, 08:18:08 AM »
spindle direction is inverted (M3 = Clockwise, M4 = Counter clockwise) So when you chose the option CW in SolidCam, your spindle will turn in the wrong direction
It is easy to fix withe a texteditor, like notepad. Maybe it's fixed already (?)  ???

Also greetings from Holland!  ;D

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #5 on: July 01, 2007, 07:02:37 PM »
Debos,
    Are you sure they are inverted in solidcam or is it the way your spindle is wired or your the way your outputs are set up in Mach? I have a couple of ideas to help with this in any case. Is solidcam the only way you generate code or do you use other cam packages as well? If you type in M3 in mdi, which way does your spindle turn?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #6 on: July 02, 2007, 01:33:43 AM »
I know for sure. I use all sorts of CAM programs, so I noticed it by reading  the generated gcode (did that after the crashed tool ::) )  It's wrong in the post processor code

Code: [Select]
@start_tool
if only_xyz eq false
    if tool_direction eq CW then
        mcode = 4
    else              ;  CCW
        mcode = 3
    endif

    call @gen_nb
    {'S'spin:integer_def_f, ' M'mcode}
    call @gen_nb
    {'M8'}
endif
endp

You see, it sais CW mcode=4 and CCW mcode=3. I editted it, now everything is fine.

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #7 on: July 02, 2007, 07:47:14 AM »
Yup, that'll do it. Glad you got it.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #8 on: February 27, 2009, 02:10:59 PM »
is there a solidcam post processor for 4 axis to work with mach3?
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #9 on: March 30, 2010, 03:09:21 PM »
Hi
When i make an array (nesting) of my part in solidcam  whit the command Transforme ->Translate->Matrix.. Mach3 halts on a line wich starts whit "while"
I've using the mach3 postprossessor.

%
O5000 (SAETREGAARDENMYNT.TAP)
( MCV-OP ) (28-MAR-2010)
(SUBROUTINES: O2 .. O4)         
G90 G17
G80 G49 G40
G54
G91 G28 Z0
G90
M01
N1 M6 T1
(TOOL -1- MILL DIA 3.0 R0. MM )
G90 G00 G40 G54
G43 H1 D31 G0 X0. Y-10. Z20. S1000 M3
M8
#21 = 0
WHILE [#21 LT 3] DO 1
(---------------------)
(P-CONTOUR-T1 - POCKET)
(---------------------)
G0 X0. Y-10. Z10.
   Z2.
G1 Z-0.2 F330
G3 X0. Y-10. I0. J10. F3000
G1 Y-10.2

Is there any changes that i can do in the .mac/gpp files to fix this?