Hello Guest it is November 21, 2019, 07:11:58 PM

Author Topic: Solidcam 2006 Rev10 to mach2-mach3 post pro  (Read 99142 times)

0 Members and 1 Guest are viewing this topic.

Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #50 on: February 21, 2015, 11:13:49 AM »
I also have a problem with postprocessing for my EMCO 5 CNC turn. Oldraven can you please send me turning MACH30T.gpp and MACH30T.mac
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #51 on: February 21, 2015, 12:38:05 PM »
My MACH3 postprocessor use for G02 and G03 R instead of I and K definition and I have wrong radius on that command. This happens only in Mach3 controler for my lathe (in CIMCO is OK). Also X coordinate is in - and have to be in + (this I solved in notepad with REPLACE). Can someone halp me with this?
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #52 on: February 23, 2015, 05:50:06 PM »
I solved the problem. After postprocessing for turn with tool in front of piece you must replace X- with X+ and G02 with G03 and G03 with G02. After that works fine.
Re: Solidcam 2006 Rev10 to mach2-mach3 post pro
« Reply #53 on: July 21, 2015, 01:17:30 PM »
Hey,

I did put some effort myself into the SC mach post :

https://youtu.be/brfYdzQtdQs

https://youtu.be/uzifjFm5B8s

https://youtu.be/uzifjFm5B8s

https://youtu.be/uzifjFm5B8s

I've set up a github repo

Any feedback and comments welcome.


PS -- the backplotter used in one of the videos is the one from the free hsmexpress. Really nice program.
PS2 -- Since I don't have a licensed SW nor SC I go to a friend of mine, who works at a shop and they have "real" machines -- HAASes and so on, and he let's me play with their software. So it's a painfully slow process... :) I'm yet to build my own machine.