Hello Guest it is July 08, 2020, 07:27:04 AM

Author Topic: incorrect dimensions when inverting x axis  (Read 7498 times)

0 Members and 1 Guest are viewing this topic.

incorrect dimensions when inverting x axis
« on: September 14, 2010, 03:28:48 PM »
we are using the same millingmachine under two profiles
the profile 'left' with 0 of X axis left and with limits setting for motor homing on NOT inverted
the 'right' profile with 0 of X axis to the right and X axis motor homing INVERTED
now when using the same G code on the same machine in the two different profiles we become two different results
one profile with the non reversed homing all dimensions are fine and with the reversed homing all circles are ALL 1mm smaller
in the G code G40 is set the two profiles are identical (except homing direction of X axis)
can anyone help in this strange behavior (we use this method to mill at the faces of a board) 

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: incorrect dimensions when inverting x axis
« Reply #1 on: September 14, 2010, 03:54:27 PM »
Can you attach both xml's please.
Hood
Re: incorrect dimensions when inverting x axis
« Reply #2 on: September 14, 2010, 04:07:16 PM »
here they are
thanks in advance
aw

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: incorrect dimensions when inverting x axis
« Reply #3 on: September 14, 2010, 04:47:42 PM »
Looking at the xml's I dont see a problem although you have Enhanced Pulsing disabled, is there a reason for that?
I presume the DROs are showing correctly so cant think how I can test but you say circles are 1mm smaller, is that both X and Y or are they oval?
Wonder if using G51X-1 at the start of the code and a G50 at the end would be a better way for you to reverse things, would that  be possible with the way things are set up?
I will look again at the xmls and see if I can pick up on anything.
Hood

Re: incorrect dimensions when inverting x axis
« Reply #4 on: September 14, 2010, 05:09:57 PM »
there is/was no reason to disable enhanced pulsing..
No the circles are real circles no ovals
we tried your G51X-1 method but this is not a good way because  we intend to reverse the board and align it to the other symetric side of the machine because we have only one boardside that is referenced

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: incorrect dimensions when inverting x axis
« Reply #5 on: September 14, 2010, 05:22:11 PM »
Ah Ok, I was wondering if that might be the case with the reversal.
Strange how both X and Y are out, is it just on circles or are other dimensions short?
Do the DROs read correctly?
Hood

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: incorrect dimensions when inverting x axis
« Reply #6 on: September 14, 2010, 05:47:54 PM »
Which xml is giving you the issue?
Hood
Re: incorrect dimensions when inverting x axis
« Reply #7 on: September 14, 2010, 05:53:32 PM »
About the DRO's, we did not verify yet
YES we have the same problems with a square cut to
it seems more like an unwanted 'cutter radius compensation' because we have always the same faulty distance
in litlle or large figures
is there a way to really force the G40 command?
in attach a test G code we used to define the faulty dim's
thanks in advance
a.willems (belgium at five to midnight )

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: incorrect dimensions when inverting x axis
« Reply #8 on: September 14, 2010, 05:55:40 PM »
The reason I asked which xml has the problems is I notice in one of them there is a tool dia of 0.5 and I am wondering if that could be the issue?
Hood
Re: incorrect dimensions when inverting x axis
« Reply #9 on: September 14, 2010, 05:58:10 PM »
the good one with correct dims is the XML file with 'LINKS' in its name
a.willems