Hello Guest it is October 16, 2019, 04:34:09 PM

Author Topic: Verify moves Y axis the wrong way  (Read 3540 times)

0 Members and 1 Guest are viewing this topic.

Offline derek

*
  •  201 201
    • View Profile
Verify moves Y axis the wrong way
« on: September 11, 2010, 08:22:07 AM »
Hi
Verify has been working properly for me for a while now. I just installed new Dugong drives and their BOB. With the new setup I had to reverse the Y axis direction in Homing Limits screen.  When I reference the drive it moves in the proper direction ( Y-) but when I use the verify button it moves in the Y+ which is away from the switch. X and Z work as they should.

Any ideas on this one?

Thanks
Derek

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #1 on: September 11, 2010, 10:41:23 AM »
Cant think why that would happen if the homing goes the correct way.
When you verify does the DRO also show it going the wrong way?
Have you restarted Mach after your changes?
Hood

Offline derek

*
  •  201 201
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #2 on: September 11, 2010, 10:57:35 AM »
Cant think why that would happen if the homing goes the correct way.
When you verify does the DRO also show it going the wrong way?
Have you restarted Mach after your changes?
Hood

Yes I always get the weird ones!

I restarted, and changed the axis direction back and fourth and restarted.  The Y axis DRO counts in the direction of movement so it's commanding it to go Y+. Also the Y will keep going until the other 2 axis touch off and then the Y reports back what ever distance it has traveled as it's error.
I really like the verify feature especially when you make changes to the machine and want to keep an eye on error.

Derek

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #3 on: September 11, 2010, 07:47:25 PM »
I am afraid I dont have a clue but if you want to attach your xml I will see if I can simulate here and see if I can figure out what the issue is.
Hood

Offline derek

*
  •  201 201
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #4 on: September 11, 2010, 07:50:42 PM »
I am afraid I dont have a clue but if you want to attach your xml I will see if I can simulate here and see if I can figure out what the issue is.
Hood

Thanks Hood
I'll send it along on Monday when I'm back at the shop.

Derek

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #5 on: September 11, 2010, 07:52:34 PM »
Ok :)

Offline derek

*
  •  201 201
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #6 on: September 13, 2010, 02:03:39 PM »
Here you go.
I sure hope you see something!

Thanks
Derek

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #7 on: September 13, 2010, 02:58:45 PM »
Try using the standard Mill screen and see if it still happens. I have simulated with your xml and both homing and verify will move the Y axis in the negative direction according to the DRO.
Hood

Offline derek

*
  •  201 201
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #8 on: September 13, 2010, 03:15:19 PM »
Try using the standard Mill screen and see if it still happens. I have simulated with your xml and both homing and verify will move the Y axis in the negative direction according to the DRO.
Hood

I'll give it a try and report back.
Thanks for the help
Derek

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Verify moves Y axis the wrong way
« Reply #9 on: September 13, 2010, 03:17:46 PM »
If it doesnt help then possibly Mach is corrupt so a install over itself may help.
Hood