Hello Guest it is August 24, 2019, 12:38:57 PM

Author Topic: Safe z turned off ignoring safe z problems  (Read 5870 times)

0 Members and 1 Guest are viewing this topic.

Offline Fleck

*
  •  31 31
    • View Profile
    • fleckguitar.com
Safe z turned off ignoring safe z problems
« on: July 18, 2010, 09:29:43 PM »
Hi,
 I am just learning Mach and am having a intermittent issue when trying to use work offsets.
Sometimes I can go to g55 zero, but mostly all is stopped and status gives a safe z is turned off ignoring safe z move.
If I restart program I cane go to zero again. I have turned safe z on and when I do that, I get no move and no message. I am using a k2 3925 servo equipped with limit switches. Any advice is appreciated.
                          Thanks Mike
             
this is my router, there are many like it but this one is mine

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Safe z turned off ignoring safe z problems
« Reply #1 on: July 19, 2010, 02:21:55 AM »
How have you got safe Z set up?
How are you commanding the move to "g55 zero"

Hood

Offline Fleck

*
  •  31 31
    • View Profile
    • fleckguitar.com
Re: Safe z turned off ignoring safe z problems
« Reply #2 on: July 19, 2010, 03:18:07 AM »
Thanks for the reply.
Quote
How have you got safe Z set up?
  My machine is new and until this week safe z has been turned off, but I now want to use work offsets. I have tried turning on safe z with a value of -.5,0 and .5 to machine coordinates with no success. I did not close and re-open program after making the changes, maybe I should have.
  When I turn safe z on "Go To Zero" doesn't work at all, nothing is listed in status bar as a problem.

Quote
How are you commanding the move to "g55 zero"
  I have machine offset coordinates set up in offset box for G55 where I would like G55 0 to be. When I turn machine and CPU on, I am going directly to offsets tab and switching from G54 to G55, then I go back to program run and use the "Go To Zero" function.  Sometimes it works.  If it does not work I have to restart CPU for "Go To Zero" to work again.
                                                                                       Thanks again.
                                                                                                   Mike
this is my router, there are many like it but this one is mine

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Safe z turned off ignoring safe z problems
« Reply #3 on: July 19, 2010, 08:02:58 AM »
A safe Z in Machine Coords should be no higher than 0 or should be a negative number, this is because your zero for Z axis is fully retracted when in Machine Coords. So your -0.5 should be fine but the +0.5 is not.

As a test use the MDI Line and type in G55 and see if the coords in the X Y and Z DROs change.

Also if you can attach your xml for the profile you use I will have a look.
Hood

Offline Fleck

*
  •  31 31
    • View Profile
    • fleckguitar.com
Re: Safe z turned off ignoring safe z problems
« Reply #4 on: July 20, 2010, 12:28:37 PM »
After restarting CPU yesterday with safe Z changed to ON at a Z value of 0 machine, things seem to be working well. I am pretty sure some of my problems are coming from trying to learn how to setup G55,56 etc. .
                                                                              Thanks
                                                                                        Mike
this is my router, there are many like it but this one is mine