Hello Guest it is October 17, 2019, 07:17:25 AM

Author Topic: Cannot Figure out  (Read 2400 times)

0 Members and 1 Guest are viewing this topic.

Cannot Figure out
« on: July 13, 2010, 08:27:10 PM »
Hi I have been working on the software part of my build and I am stuck. I load one of the sample programs from the mach3/gcode folder and watch what it does in the toolpath window but the tool path (in green dashes) does nothing but circles the shape is there but and it will turn from purple to white as yop single block thru it but the toolpath just does circles and does not follow the part / shape. I went thru the tutorials and then skimmed them again but I can't find anything on a setting  I missed. Also I tried programing a simple square and it will only draw the first 2 legs. here is the code
G00 G17 G20 G40 G49 G50 G64 G80 G91;
G54 ;
G28 X0 Y0 Z0;
G00 X2.0 Y2.0;
G43 H1 Z.1;
G01 Z-.1 F25.0;
G01 X4.0 Y0 F50.0;
Y4.0 ;
X0 Y4.0;
 Y0;
G28 X0 Y0;
M30; 
What am I missing?
Thanks for your help

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Cannot Figure out
« Reply #1 on: July 14, 2010, 06:19:52 AM »
Spitter,

Changing the G91 (incremental) to G90 (Absolute) in the first line will help a lot.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Cannot Figure out
« Reply #2 on: July 16, 2010, 06:24:41 PM »
Thanks I was getting really confused between the incremental and absolute in the post processor and programming and the other thing but I do get confused with two things, a little dyslexia I think. But on to another thing I can't figure out ;) i can move my machine around using the keyboard in the program run screen. I can move it around in mpg when I hit the tab button I can even move it around using the mpg axis buttons in the positive and negative, but when I change jog mode to step I can no longer move my machine. I can't even move it when I tab out of mpg. I have to move jog mode back to continuous and then tab out and hit reset then I can move it again. I need to move in .01 increments so i can touch off my tool.
thanks for your help
Scott
Re: Cannot Figure out
« Reply #3 on: July 18, 2010, 06:11:12 PM »
I got it. i can do .01 increments or whatever. I tried adding a joystick and when I got the joystick up and running I had the increments.