Hello Guest it is August 23, 2019, 11:40:19 PM

Author Topic: Problem with Pins 2-9 as inputs  (Read 2160 times)

0 Members and 1 Guest are viewing this topic.

Problem with Pins 2-9 as inputs
« on: February 04, 2010, 12:59:07 PM »
I am having a problem, if i select pins 2-9 as inputs everything works well until i restart the PC. It seams to forget that pins 2-9 are inputs even tho the box is still checked off.

If i uncheck the box, click apply, then check the box then click okay it works, until the computer gets restarted again.

Any suggestions on how to fix this problem?

Thanks,
- Bochek

Offline RICH

*
  • *
  •  7,351 7,351
    • View Profile
Re: Problem with Pins 2-9 as inputs
« Reply #1 on: February 04, 2010, 01:48:13 PM »
Which port, i will assume port 1 and that it is enabled.
Are you duplicating pins by some chance as those are often used for the motors, don't need to.....
You can use the Automated Setup Of inputs dialog, i have never used it, but may be worth a try.

A long while ago, with one of the versions ( don't remember which version), i had a problem with Mach not accepting the input values and it took a number of times for it to save them. I just wrote it off as a fluke!

What version are you using?

Post your xml file and the pins you want assigned and we can take a look.


RICH
Re: Problem with Pins 2-9 as inputs
« Reply #2 on: February 04, 2010, 01:50:30 PM »
Its port 2.  And sorry but im not currently at the machine, i can get that info for you later!

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Problem with Pins 2-9 as inputs
« Reply #3 on: February 04, 2010, 02:14:07 PM »
As an experiment could you swap the cable from Port 1 to Port 2 and vice versa, change the address's accordingly and also the ports  in ports and pins setup. I am thinking this may be some sort of card problem and doing so would let you know for sure if its a Mach issue or a Card issue.
Hood