Hello Guest it is October 14, 2019, 10:13:48 PM

Author Topic: Ncpod is not recognized  (Read 13281 times)

0 Members and 1 Guest are viewing this topic.

Ncpod is not recognized
« on: February 01, 2010, 11:45:26 AM »
Hello everybody,

I am building my first cnc..its all new for me..

I am just got all the parts too connect my cnc to the computer..yeahhhh ;D
the powersupply and driver cards are all on green leds and i see no smoke  8) thank god

I also have connected the ncpod to a adapter (4,65 volts and 300 ma) and to the usb..on my comp. whit mach3
but i dont see the ncpod leds light up and i can not recognize the ncpod..
but the ncpod gets little bit warm..so it gets power right??

i installed the drivers ..and the plugin

i cannot install the firmware because it is not recognized yet???

what am i doing wrong here..or is my ncpod allready broken or??? :-\
Ralf Klaassen Timmerwerken
www.ralfklaassentimmerwerken.nl
Re: Ncpod is not recognized
« Reply #1 on: February 02, 2010, 02:29:42 PM »
Hello ,


Ncpod is working now..that problem is solved.. ;D (power supply was not good connected) leds working now..drivers installed whit latest firmware

Ncpod have +5..grd(-5)..step and dir wires for motor outputs..and the ME742 has Pul+/Pul-/Dir+/Dir-/Ena+/Ena-

What i understand from the diagram i need +5 to connect too Pul+
                                                             Pul connect to Pul-
                                                             Dir connect to Dir -

Where should i connect the gnd(5-) wire??????

Ena + and -  needs to be unconnected if i am correct..because that disables the driver when connected.

Please somebody helpp  :)


Ralf Klaassen Timmerwerken
www.ralfklaassentimmerwerken.nl
Re: Ncpod is not recognized
« Reply #2 on: February 03, 2010, 12:58:29 PM »
Hello,

everything working now ;D..only now the Master and slave axis is turning same direction.
I can not reverse it in mach3..does not work

Also when i ref all axis to zero and regen..al is ok ..but when i reset the coordinates change to last cordinates again..when i reset again it go to 0 again..and so on..and so on??

does anybody have had same problems??

greetz ,
Ralf



Ralf Klaassen Timmerwerken
www.ralfklaassentimmerwerken.nl

Offline Graham Waterworth

*
  • *
  •  1,888 1,888
  • Yorkshire Dales, England
    • View Profile
Re: Ncpod is not recognized
« Reply #3 on: February 03, 2010, 01:42:55 PM »
Hi Ralf,

it is sad to say but the NCPod is not very well covered here, The moderator has not kept up to his promise so support is very limited, sorry but you may be one of only a hand full of users.

To reverse the Y axis you need to swap one pair of motor wires over.

Good luck.
Graham
Without engineers the world stops
Re: Ncpod is not recognized
« Reply #4 on: February 03, 2010, 02:20:50 PM »
When everything is working i will make a good video on youtube..and try too explain as much as i can.. ;D
Ralf Klaassen Timmerwerken
www.ralfklaassentimmerwerken.nl
Re: Ncpod is not recognized
« Reply #5 on: February 03, 2010, 02:23:02 PM »
Thanks for th info graham in the PM  ;D

Ralf Klaassen Timmerwerken
www.ralfklaassentimmerwerken.nl
Re: Ncpod is not recognized
« Reply #6 on: March 02, 2010, 11:25:04 AM »
I have ncpod working but really need homing to work also, can't seem to accomplish this. If anyone could provide me with the latest version of mach and ncpod drivers that work I would really appreciate it. Also what do you set up in ports and pins for homing switches, from what i have read ncpod takes care of the homing function. Also is there a special oem code for homing with ncpod.

 I'm using a laptop so ncpod is best option for me at this time. One note is when i go to the nc pod screen x,y,and z homing/limit boxes are flashing, should they be solid based on switch condition?

Thanks for any help
Re: Ncpod is not recognized
« Reply #7 on: March 02, 2010, 04:20:54 PM »
The latest version of mach and ncpod are on the mach site "downloads"

I am waiting for some parts too finish my cnc..but i have the reference switches allready working on ncpod
make sure that active low is on in "input signal" at "ports and pins"

Port 1 and pin 1 i use (up to yourself to deside)

dont use pin 2 and 3 because its for the emercency button and the probe..the rest of the pins you can deside for yourself

I am also experimenting whit my ncpod ..so dont assume i am 100 % right but thats what i know so far..good luck  ;D
Ralf Klaassen Timmerwerken
www.ralfklaassentimmerwerken.nl
Re: Ncpod is not recognized
« Reply #8 on: March 02, 2010, 04:23:15 PM »
port 1 and pin 1 i use for x
port 1 and pin 4 i use for y
port 1 and pin 5 i use for Z

port 1 and pin 2 i use for estop
Ralf Klaassen Timmerwerken
www.ralfklaassentimmerwerken.nl
Re: Ncpod is not recognized
« Reply #9 on: March 02, 2010, 05:59:32 PM »
Hi Ralf

Thanks for the reply. So I take it your not using the built in homing inputs of the pod. I got it working finally but still acts strange some times on dro zeroing, when the first axis zero's it zero's all axis. Also sometimes it homes and sometimes I need to ref home a few times for it to go.

Mike