Hello Guest it is May 17, 2021, 11:38:54 AM

Author Topic: Acceleration problem  (Read 5804 times)

0 Members and 1 Guest are viewing this topic.

Offline faby

*
  •  74 74
    • View Profile
Acceleration problem
« on: September 22, 2006, 10:02:50 AM »
I have a problem milling at medium and high speeds.
If I mill a square, the corners are rounded, as much as increase the speed.

here attached you can see the problem, I milled the same square at 3 different speeds.

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Acceleration problem
« Reply #1 on: September 22, 2006, 02:35:57 PM »
Hi, Faby

Your probably in CV mode, goto Config, General Config, find Motion Mode if it's in Constant Velocity change it to Exact Stop.

Hope that's It, Chip

Offline faby

*
  •  74 74
    • View Profile
Re: Acceleration problem
« Reply #2 on: September 22, 2006, 05:50:49 PM »
If I change that, it works fine, but only if I mill simple object like square.
When I mill a 3D path, I can't use the exact stop mode, because my machine works so crispy (I don't know if it's the right word :-D).
It doesn't move smooth at all.
I need the cv mode but not the rounded corner.

Thanks

Hood

*
Re: Acceleration problem
« Reply #3 on: September 22, 2006, 06:00:28 PM »
you could put a G61 in the code when you want precise corners then G64 to go back to CV when you have finished your squares.
Hood

Offline faby

*
  •  74 74
    • View Profile
Re: Acceleration problem
« Reply #4 on: September 22, 2006, 06:14:42 PM »
are you kidding?
In a 10Mb 3D program? or in a complex 2D program? I can't it's impossible.

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Acceleration problem
« Reply #5 on: September 22, 2006, 07:33:29 PM »
Hi, Faby

< are you kidding? >

You could use your CAD, use a layer for your Square stuff and another for your are your CV stuff, then use the G61 and G64 only 1 time each.

May-be your motor tune-ing need's some attention.

LazyCam will let you change your feeds and speeds for each layer.

Think about it, Chip

Offline chad

*
  • *
  •  361 361
  • When the going gets weird, the weird turn pro.
    • View Profile
Re: Acceleration problem
« Reply #6 on: September 23, 2006, 03:03:05 AM »
HI, i have a suggestion. I am not sure if it will work but you might want to play with it any way. I also suspect that 8000 mm per is just to fast for the power of your steppers, not a mach problem just a machine limit. 

Go to the settings screen and under angular limit change the angle to say, 30 and enter a speed that works ok like, 3000mm-s.

The way i think this works( art or Brian please correct me)  is when the look ahead sees a direction change coming up it slows down the output to something that your machine can handle based on what you set in the field. So for a corner if your machine chokes at 8000mm per  on a 90' corner than you can tell mach to slow down on any angle >  (whatever you set) and go to a alternate feed rate.

To the best of my experimentation this is how it works.
 My guess it is in the program to compensate for machines that are faster on single axis moves than coordinated moves. ??

Chad



Offline chad

*
  • *
  •  361 361
  • When the going gets weird, the weird turn pro.
    • View Profile
Re: Acceleration problem
« Reply #7 on: September 23, 2006, 03:21:14 AM »
I am an imperial measurement guy and I just converted 8000 mm per min and that comes to 314.96063 ipm, that is moving VERY fast. I have a Bridgeport style mill with 1.2 kw ac servos and i can move that fast but it is scary and will eventually shake my machine apart if i ran it that fast.
To put It into perspective if you were cutting 3/4 (19.5mm) MDF with a 1/2 (12.7mm) bit at 18,000 rpm you would have to be at 288 ipm with a minimum of 5 horsepower ( 3750 kw spindle ) to get the correct chip load at .008 for a two flute carbide spiral router bit.

In other words you probably won't be able to cut anything at 8000mm per unit any way.   so slow it down to what your machine can handle...

Just some thoughts...


Chad

Good luck ;)

Offline faby

*
  •  74 74
    • View Profile
Re: Acceleration problem
« Reply #8 on: September 23, 2006, 04:08:57 AM »
My machine doesn't loose steps at 314.96 ipm (8000mm/min) because in the mach toolpath simulation it draw the same rounded corner.
I don't wan to to cut mdf or other material at 8000, I produce mould for fiberglass, and I need to mill 3D objects with a smooth finish, so the milling machine has to remove thin layers, like 0.1mm, at high speed.

I let my mill to go at 8000 only for make the problem bigger, but it to the same problem at 5000 or 3000, only smaller round.
You can see an example of what I do in this video, it's a test only

www.fxmodel.it/lightspeed.wmv

Just for answer to chad (wow nice machine your :-) ) I set the "look ahead" value to 50 lines, but don't matter, because in a square there's only 4 lines of program right?.

Thanks for all to all of you :-)

Offline fdos

*
  •  326 326
    • View Profile
Re: Acceleration problem
« Reply #9 on: September 23, 2006, 12:25:59 PM »
Your problem as you realise if a result of CV mode.   To achieve CV Mach HAS to do corner blending, otherwise it's Exact stop mode.

I'm not sure what the angular discrimination tick box is for in config, but it's almost sounds like what we had with Heidenhain control parameters. 

These controls would do the corner rounding but ONLY if the change of angle was below a value stored in the the parameter table.   Heidenhain used to recommend it was set to no higher than 30 degrees.

Anyone know what the angular discrimination box is for?

But I would do as Hood suggested.   In my cam package I can put in manual code anywhere in the program.

Wayne...