Hello Guest it is August 11, 2020, 01:00:00 AM

Author Topic: Mach3 R3.042.033 overfeed bug  (Read 10684 times)

0 Members and 1 Guest are viewing this topic.

Re: Mach3 R3.042.033 overfeed bug
« Reply #10 on: December 31, 2009, 09:48:10 AM »
No. I have a 4 axis mill and controller that has gecko 201 drives, charge pump, 3 home switches and a probe, nema23 250oz-in 0.9deg steppers, and a couple 110VAC relays and my computer is more than ample to run mach, using XP pro. I've been through many versions of mach over the past 4 years and all have worked fine for the most part.

 I went back to ver 0.020 and velocity behavior goes back to normal. Tried version 0.033 again after that and overfeed happens so there is definitely a software issue. I do use my own screen set, I'm going to try to use the default install, screen, and xml to see if maybe something from my screen set iis causing this. I have 2 machines so I will also try this on my other machine.
« Last Edit: December 31, 2009, 10:53:49 AM by swarfboy »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #11 on: December 31, 2009, 11:15:24 AM »
Doesnt seem to be anything there, I did notice you had a custom screen but I very much doubt it will have anything to do with that, it is more likely to have something to do with the threading code that Art has done as it seems to have caused other problems for the select few, you should feel privileged you have joined an elite group  ;D

 Will be good to hear how you get on with the other machine, presume its a different computer?

Hood
Re: Mach3 R3.042.033 overfeed bug
« Reply #12 on: January 05, 2010, 01:49:00 PM »
I downloaded and test all versions of Mach between 0.20 and 0.33 excluding 0.32 as I didn't see it on the server.
The velocity calculation changed began significantly overfeeding in version 0.30. With motor velocity max set to 850mm/min the machine jogs at 1115mm/min. Please look into this. I can reproduce this on 2 machines.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #13 on: January 05, 2010, 01:52:08 PM »
What CPU do both of these machines have? Is it actually an overfeed or is it the DRO reporting wrongly?

Hood
Re: Mach3 R3.042.033 overfeed bug
« Reply #14 on: January 05, 2010, 02:25:19 PM »
AMD Athlon 2000+/2100+
FSB 133
1.0GB RAM

The machine is traveling at a faster velocity, I can see and hear it, and the DRO is reading faster.

Some change the occurred in 0.30 caused this.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #15 on: January 05, 2010, 02:34:05 PM »
Strange, have seen reports of weird spindle speeds being seen with these latest revisions and its always been faster CPUs I think,  yours is the first with the overfeed.
  I think 030 was the version that the new driver for the threading was added but not sure, will ask Art and see if he can look in on this post.
Is there a specific reason you need 030 onwards?
Hood
Re: Mach3 R3.042.033 overfeed bug
« Reply #16 on: January 05, 2010, 02:48:05 PM »
Immediately no, but I don't want to see the bug persist into future versions as I'd like to be able to install newer releases and enjoy the feature additions and bug fixes.
It's odd that I'm the only person experiencing this when I have had it working fine since  early Mach3 1.x versions and now it changes in v0.030.

My spindle is controlled by a potentiometer on the spindle controller not through Mach, so I can not verify that issue.
« Last Edit: January 05, 2010, 02:50:54 PM by swarfboy »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #17 on: January 05, 2010, 03:13:04 PM »
Rev 4 is a major upgrade, in fact its a total overhaul so unlikely bugs will be passed on from earlier revisions but even if there are bugs Rev4 will make them easier to sort as it will be in modules and fixing one thing will not break something else which is a problem at the moment from what I gather.
 You are certainly the first report I have seen with this problem, thats not to say you are the only one, just no one else has reported it yet.

It was the spindle speed readout I think that seems to be messed up but I am just thinking it could be related as it was about that rev that the new driver code was added.

Hood

Offline Greolt

*
  •  956 956
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #18 on: January 06, 2010, 04:00:10 AM »
I have been seeing this also.  By a lesser margin than Swarfboy is getting.

Check what the Pulse Frequency is on the diagnostics page.  I run 35k and am getting 35317 reported.

Seems to have arrived with the latest driver upgrades.  

I thought it was rather good, as my pulse frequency has always been lower than kernal speed, on every computer I have used since I started with Mach.  :)

Greg
« Last Edit: January 06, 2010, 04:03:32 AM by Greolt »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #19 on: January 06, 2010, 04:26:32 AM »
There is a new revision just posted (034)  try that and see if it helps.
Hood