Author Topic: Mach3 R3.042.033 overfeed bug  (Read 9959 times)

0 Members and 1 Guest are viewing this topic.

Offline swarfboy

  • Active Member
  • Posts: 71
    • View Profile
Mach3 R3.042.033 overfeed bug
« on: December 29, 2009, 04:13:42 PM »
I upgraded from version 0.20 to 0.033 and find that 0.033 is overfeeding by around +25% on Jog and G0 and G1 moves.

Offline Hood

  • Mach4 Alpha
  • Posts: 25,775
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #1 on: December 29, 2009, 04:38:11 PM »
are you meaning distance or velocity?

Hood

Offline swarfboy

  • Active Member
  • Posts: 71
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #2 on: December 30, 2009, 10:31:54 AM »
Velocity definitely and possibly acceleration too but its hard to perceive if its over accelerating.

Simple test.
My motor tuning is set to 1000mm/min for X.
Jog X and the velocity reaches approx 1250mm/min. It shouldn't go over 1000mm/min and doesn't in older Mach versions such as 0.020.
I upgraded from 0.020 to 0.033 so I don't know what version this bug as introduced.

Offline Hood

  • Mach4 Alpha
  • Posts: 25,775
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #3 on: December 30, 2009, 02:52:59 PM »
Not heard of that one before, can you attach your xml and I will see if I can replicate it.
Hood

Offline RICH

  • Global Moderator
  • *
  • Posts: 7,305
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #4 on: December 30, 2009, 05:23:01 PM »
I just loaded Version 033 and checked the lathe axis and the feedrate in joging steps or G01 is spot on.   ???
Did you do any motor tuning and not go out and back into Mach?

RICH

Offline swarfboy

  • Active Member
  • Posts: 71
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #5 on: December 30, 2009, 08:15:07 PM »
Didn't change any of my settings. Copied myscreen.set, machlic.dat, mach3_4axis.xml, my macro folder, my image folder, my machmill shortcut that loads my profile. Uninstalled mach3 0.020, deleted c:\mach3r, installed mach 0.033, rebooted, copied my files back, started mach.

I've done this 2x now and both times mach overfeeds velocity by about 25% on all jog and feed moves.

Attached is my .xml

Offline Overloaded

  • Global Moderator
  • *
  • Posts: 4,783
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #6 on: December 30, 2009, 09:18:35 PM »
Just ran you xml and see the tuning is set the same for all axis's...not 1000 but 850 and the vel dro is right on when rapid jogging.
Double check your tuning.
Hood will diagnose it better in the am.
RC

dang...forgot the pic again
« Last Edit: December 30, 2009, 09:20:40 PM by Overloaded »

Offline swarfboy

  • Active Member
  • Posts: 71
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #7 on: December 30, 2009, 10:02:25 PM »
I compensated the motor tuning to get it to run closer to my desired max velocity, but this is a workaround not a fix.

Offline Overloaded

  • Global Moderator
  • *
  • Posts: 4,783
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #8 on: December 31, 2009, 12:26:39 AM »
Oh..OK, I see.
Cant make it happen here, I'll be watching for the solution.
Good luck to ya,
RC

Offline Hood

  • Mach4 Alpha
  • Posts: 25,775
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 R3.042.033 overfeed bug
« Reply #9 on: December 31, 2009, 02:41:45 AM »
Working fine here also. Do you use any Plugins or devices such as the shuttle or PoKeys? might be worth disabling them to see if you can isolate the problem.
Hood