Hello Guest it is October 16, 2019, 11:34:44 PM

Author Topic: Parallel Port Pin 1 problem  (Read 1956 times)

0 Members and 1 Guest are viewing this topic.

Parallel Port Pin 1 problem
« on: December 17, 2009, 10:38:23 PM »
 ???

I don't know what caused this but pin 1 of the parallel port stopped functioning as my X axis step output.  I tried using pin 1 as the direction output instead to no avail.  Tried using it with the Y and Z axis, but still no success.

Has anyone had this problem before?  I am using all of the output pins, so I can't just change to another pin.  I've tried upgrading to 3.45, without success, and given the port driver causing problems with laptops, I went back to version 2.65.

I know the parallel port output is the problem as I have tested the outputs with a digital probe.  It is not my breakout board.

Thanks in advance for any suggestions.

Ken Klausner

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Parallel Port Pin 1 problem
« Reply #1 on: December 18, 2009, 11:28:45 AM »
If you can try a normal type output such as coolant on Pin 1 and see if it works, if not then it would seem your parallel port is bad.

Hood