Hello Guest it is August 05, 2020, 09:30:13 AM

Author Topic: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed  (Read 15598 times)

0 Members and 1 Guest are viewing this topic.

I purchased an ISMM2080 jog pendant and am having no joy at all setting it up. I have connected it directly to the LPT2 via a 25 pin solder plug. The instructions I have followed are via the cnc4pc link

http://cnc4pc.com/Tech_Docs/guide_for_MPG4_over_LPT2.htm


I initially thought it was the LPT2 address and it turned out I did indeed have it wrong, so reset it to 0xECF8 in mach3. As far as I know the port works fine, I can use a printer from LPT2 no problem.

I wired the pendant into a 25 pin connector as per the cnc4pc document so:

red and orange/black were connected to USB + 5v
black and white/black were connected to USB ground
green to pin2
white to pin3
yellow to pin4
yellow/black to pin5
brown to pin6
nothing to pin7
grey to pin8
grey/black to pin9
orange to pin10

the e-stop blue and blue/black were left disconnected for now until I can get it working and I dont think I need pink, pink/black, red/black and brown/black. I am fairly sure what I have done so far is wired correct. There is still a bare non coloured wire which has solder on the end and not sure what that is?

I have followed cnc4pc`s instructions manual for settings and loading the brains etc and when I plug it in the led light comes on but absolutely nothing happens.

In diagnostics the output 6 light is on.

What tests can I do to start eliminating things and hopefully reduce the hair pulling and get it sorted?
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #1 on: October 27, 2009, 09:03:20 AM »
spent some more time on it and I just cant get the output#6 light to go out on the diagnostics page  :( If I turn off all the brains it goes out but then so does the led on the MPG. I have the enable button brains and axis jog selector brains ticked.

Does someone have the mach3 settings they used for a similar MPG pendant? Do I need to set any triggers in system hotkeys?

I am not the best at electronics, how can I test this output? Its pin 1 on LPT2

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #2 on: October 27, 2009, 10:44:24 AM »
Probably best to ask Arturo at CNC4PC, I have never used any of his stuff so afraid I am no help :(

Hood
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #3 on: October 28, 2009, 07:38:37 AM »
I have had some help off Arturo but to no avail. I swapped the Gecko drive cnc controller and all the necessary mach settings over to LPT2 and the motors jog and everything works as it should so I am guessing it cant be the pci parallel port at fault. I then plugged the jog pendant into the computers standard LPT1 and nothing at all. Arghhh this is starting to get to me! Perhaps a faulty pendant? Everything seems to come back to output#6 flashing red on diagnostics.

I got mine directly from HEDSS and not from arturo at cnc4pc.com so he has been more than helpful so far.
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #4 on: October 28, 2009, 08:32:27 AM »
Dougie329 I just read the first line of the setting up page link you quoted in your first post.

For this implementation the optional C22 - Pendant Interface Board is required.  This board takes power from the USB port for powering the Pendant's circuit and also buffers all the signals to ensure reliable operation.

Do you understand what that means, i have set one up to test using the C22 interface and had no problems.

Phil
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #5 on: October 28, 2009, 11:00:23 AM »
Hi Phil, im bordering hopeless on electronics  ;D but have a sound logical engineering mind so usually get there in the end. I know that the C22 board exists however I spoke to Arturo from cnc4pc.com and he said its possible to wire directly without one which I have been trying to do using his chart.

I have also spoken to someone else off this forum who has the exact same problem which is that no-matter what I do output#6 flashes red and the MPG doesnt do anything. I may well order a C22 board today and see what happens but surely I should get something lighting up in diagnostics.

Where did you get your C22 board?

If possible could you kindly let me know the settings and which brains you have switched on in mach3 so I can eliminate any obvious errors.

Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #6 on: October 28, 2009, 12:02:53 PM »
Dougie329

I bought the C22 direct from CNC4PC, plugged it in to a Smooth Stepper port 2 followed the instructions and it worked.  ;D

Phil

The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #7 on: October 28, 2009, 07:13:15 PM »
Dougie329

I have put a new post here to tell you why you are not going to get this working the way you are going about it.

The CNC4PC setup page says set Mach pins 2-9 as inputs but and its a big but, the pins 2-9 are outputs on the parallel port, that is what the C22 does it converts the signals, something that certain BOB's can do also.

Essential things that you seem unwilling to spend money on.

Phil

The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #8 on: October 28, 2009, 07:30:03 PM »
Phill, you can opt to set pins 2-9 as Inputs in Mach for a second parallel port, some parallel ports can't do that however if they are just standard ports, they need to be set up as enhanced ports.
Hood
Re: Struggling getting MPG jog pendant to work via mach3 on LPT2 help needed
« Reply #9 on: October 28, 2009, 07:36:30 PM »
Thanks Phil

Thats all I am after, a bit of help on the why and how. There is zero information comes with this MPG pendant from the factory and all I had to go off was some bits I found on the internet. Its certainly not that I am unwilling to buy a C22 board at a few pounds, just that I didnt know exactly what it did and if I actually needed one or not. From your post I guess I do and will get one in and post back how I get on :)

Just spotted your post Hood, not sure what you mean by setting them up as enhanced ports