Hello Guest it is January 28, 2022, 06:57:43 AM

Author Topic: Web Cam not working  (Read 2421 times)

0 Members and 1 Guest are viewing this topic.

Web Cam not working
« on: September 27, 2009, 08:49:26 PM »
I can use the camera outside of Mach but when I try and use the video plugin it says it cannot start the camera.  Also there is only the Windows driver available in the dialog box and not the specific webcam driver.

Thing is it used to work but I had to rebuild my system and now it doesn't.  I tried reinstalling drivers and taking any thing off the system that I thought would have a conflict.  I searched the forums but did not find anyone else having a problem which just means I must be doing something stupid.

Windows XP SP3, Mach3 3.041, Micro Innovations IC425 webcam.

Any suggestions would be appreciated.


Offline RICH

  • *
  •  7,422 7,422
    • View Profile
Re: Web Cam not working
« Reply #1 on: September 28, 2009, 12:23:19 AM »
If it worked before it should work again ( you would think ).
I have some cameras that will not work in MACH. In fact i bought two web cams from Radio Shack, same models,
 and the one required a different driver to work in both Windows and MACH. You figure and sorry don't have an
suggestions other than the driver.

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: Web Cam not working
« Reply #2 on: September 28, 2009, 08:43:37 AM »
Try a different USB port, I seem to remember someone saying the USB port on their laptop wouldnt work the camera with Mach but when they added a USB 2 card it worked fine.


Offline ART

  • *
  •  1,702 1,702
  • Tough as soggy paper.
    • View Profile
Re: Web Cam not working
« Reply #3 on: September 28, 2009, 09:29:56 AM »
Hi Guys:

  The threading is being re-investigated as of this coming week or so. John S has agreed to run some tests for me to see where the wander is at. We're goign to start with the
Printer port single pulse threading, then evaluate the multislot again to document the differences. The wander is caused by a varying of the time the computer see's the index time.
It seems on some computers there is an inherent delay and this causes an overcorrrection that creates a wandering Z position. On other computers it seems not to exist. I still
dont know though if its the computer or the machien causing the variance. The multislot gives me statistics to see how much variance. When I feed it a time based generated pulse
I see no variance here, but using my Emco lathe, I see the index pulse varying in time.

 This means either my motor is varying in speed slightly, ( though I cant see or hear it..) or the sensor itself just isnt that solid in terms of when it activates. More test results should be
coing out soon.