Hello Guest it is December 05, 2021, 05:35:18 PM

Author Topic: Shuttle pro V2 problem  (Read 3853 times)

0 Members and 1 Guest are viewing this topic.

Shuttle pro V2 problem
« on: August 15, 2009, 03:28:40 PM »
Hi all, I posted on the download thread, but figured I would post here also.

I just got a Shuttle pro and am having problems. I've got a licensed version of mach and it has been running my shoptask for over a year. I loaded the shuttle pro plug in, configured a couple buttons, restarted mach and the shuttle will cause the leds to change as if it is working, but all the motors sit and grind with no movement. Tried deactivating the plug in by unchecking it and the same results except the shuttle doesn't do anything, just the normal jog causes the leds to change but no movement. Removed the shuttle dll and restart computer and mach works correctly.

Figured it may be a version issue, so downloaded the latest lockdown of mach and tried again. Tried with the plug in that downloaded with mach, and a couple of the other versions that are on new plug in thread. Same results for all. If the plug in is there, the motors just hum and grind with no real movement. With the dll removed, mach works normally.

Shuttle pro drivers are not installed and when I plugged it into the USB the first time, the pop up saying it was found appeared.

USB port is on the computer, shuttle wire doesn't run near the motor wires, usb port works for other hardware.

any ideas?
Re: Shuttle pro V2 problem
« Reply #1 on: August 15, 2009, 11:13:08 PM »
Did you install the software that came with the Shuttle?  If so, that could be the problem.
Re: Shuttle pro V2 problem
« Reply #2 on: August 16, 2009, 12:57:29 AM »
No, just the plug in.

Followed the instructions on the plug ins page and still have problems. If the plug in is in the Plug ins folder, motors only grind and table doesn't move. Remove the plug in dll and all works the way it is supposed to.

I tried it several times, and with a couple different versions of the plug in, and different versions of Mach3 all with the same results.

Next, I think I will try and remove the listing for it from Device Manager, and start over. Idon't understand what in the plug in would impact the stepper motors. I also downloaded the xml editor and will look at the xml file to see if I see anything amiss there.

Offline budman68

  • *
  •  2,354 2,354
    • View Profile
Re: Shuttle pro V2 problem
« Reply #3 on: August 16, 2009, 12:59:02 PM »
Just an idea to try, try putting the USB plug into a different USB port as I had a PC that had front mounted USB ports that did not work the same as the rear ports soldered to the motherboard.

Just a thought-
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)
Re: Shuttle pro V2 problem
« Reply #4 on: August 16, 2009, 08:24:26 PM »
OK, made sure the human inteface wasn't in the device manage, then plugged the shuttle pro in the USB in the rear of the computer. Put the shuttle pro dll back in the plugins folder, fired up Mach3, verified the shuttle pro plug in was there and configured for a couple buttons. Shut Mach down and fired it back up. Same problem, motors grind and table doesn't move. Next step, I'll look at the xml and post it here.
Re: Shuttle pro V2 problem
« Reply #5 on: August 16, 2009, 08:31:44 PM »
Just for the excersize of 'process of elimination'.  Do the other functions on the Shuttle work?  I.O.W.- If you have a button to toggle your spindle does that work?  Can you select different Axi (a message shows in the message dialog in Mach)?  I'm just trying to isolate if this is just related to miving the motors or a total Shuttle meltdown?
Re: Shuttle pro V2 problem
« Reply #6 on: August 16, 2009, 08:38:45 PM »
Found the problem, may ba a Mach3 bug. Even though the plug in box showed a check mark in the drop down, the .xml had a 0 for the shuttle plug in. I changed the .xml to show a 1 for the shuttle, saved the xml, and now it works. I haven't tried it all yet, but at least I can now run the axis with the shuttle.

Brian, you may want to check into this behavior.

I'm out of town this week, so I won't have a chance to do more testing 'till next week.