Hello Guest it is June 03, 2023, 09:46:43 PM

Author Topic: motors no go in mach 3...  (Read 13017 times)

0 Members and 1 Guest are viewing this topic.

Re: motors no go in mach 3...
« Reply #10 on: June 13, 2009, 05:34:50 PM »

Chip had me download the parallel port monitor, here.


and see if i was getting activity on my port.

If you think the port is the issue, I'd download this and get the port working,
you can see activity on the port as the "lights" flash on the app.

There is a setting to made it stay on top so you can see it while other applications are running.
I don't' remember where it was exactly but i found it after a few tries.

If you can't find it, let me know.

If you need more info about parallel port stuff and diagnostic tools, I found this site helpful.
I'm a fairly technical PC guy, even if I'm a complete Newby to CNC, but it was useful.

As to my Issue, I figured it out it was an   Id10t Error, my Dir and step pins were reversed in the
port config. all 4 axis are working fine now.

Thanks for the help everyone!

Re: motors no go in mach 3...
« Reply #11 on: June 14, 2009, 08:12:23 AM »

Thank you for the link. I actually found one yesterday just before you posted this at http://www.xmediastudio.com/PortTester.php.

I did some work last night (I work the weekends 12-hour shifts) and can see the direction pins toggling. I even see the 5vdc on the controller end of the cable. All of my pins are set up correctly in pins&ports since I have a printout of the Mach3 setup windows with the correct ones on it.

I am at a very odd stage now. The controller is comprised of three separate drive boards, one for each axis and I have tried to isolate it to a specific board or motor to no avail. I have also checked the voltage on the power supply and even checked it for loading during movement and it stays rock steady.

I am back to the possibility that something is corrupting the pulses from the computer (I do not have an o'scope to check them) so I am going to try one more thing...

I run an X10 controller on my powerline of the house and have decided to pull this off of the line to make sure that it is not throwing pulses on the powerline that are effecting the power supply of the controller.

I will let you know how it goes. If this does not work I will have to figure something else out.

Re: motors no go in mach 3...
« Reply #12 on: June 14, 2009, 09:11:03 AM »
I think that I will double check this enable setting since I have found three posts where this turned out to be the problem. Is there any reason that this enable would change from the original other than one changing it?

Re: motors no go in mach 3...
« Reply #13 on: June 14, 2009, 11:27:35 PM »

I don't know but i know that the same xml file was working 6 months ago when i
started building the bigger router, in 3axis mode with the same controller and motor.

I have to assume i did something, but I sure don't remember doing anything.