Machsupport Forum

Mach Discussion => General Mach Discussion => Topic started by: caladin on June 10, 2009, 12:45:02 AM

Title: motors no go in mach 3...
Post by: caladin on June 10, 2009, 12:45:02 AM
Hi all,

I've got my cnc router working, it's my 2nd one, but I only used the first to get the
software working with my electronics & motors.. it was a terrible $100 design, and by then all the parts for the "good" one has arrived.:)

so I wired everything up,  took the setup that worked with the same electronics & motors, activated the 4th axis (x2), set the pins * ports, accel etc.

The test app that came with the board gets movement just fine, but mach 3 no movement. i go to the diagnostic screen, and
It shows no traffic over the port.

the port is the same as the tool that works is using.

Any ideas?


Title: Re: motors no go in mach 3...
Post by: jimpinder on June 10, 2009, 03:09:49 AM
I am not sure exactly where you are.

I take it Mach is installed in a computer, and works without any machine being connected to it. You can run programs etc and watch the software "cutting" your pattern. I take it the drivers are properly installed. If you are not at this point, then this should be your first proirity. Disregard any router, and get the Mach software running. Fill in the port and pins details (and activate them) as though you had a machine connected. If you can calculate your steps per unit for your new router motors, enter that. In other words do everything just as though your router was connected.

You do not say what connection there is to your router elctronics from your computer. I use the printer port, many now use a smooth stepper etc. If you are using the printer port, it is a simple matter to connect the cable, and test the various pins with a multi meter to see if signals are being sent. I must admit is you are not seeing anything on the diagnostics page, then you must probably have some settings incorrect - like enabling each axis, or entering the prot number as well as the pin.

You do not say what your drivers are (gecko etc? ) or what your motors are (200 step steppers ?) Are you using a breakout board ?

If you can set out where you are a bit more clearly, we will be able to help you with the problem.

Title: Re: motors no go in mach 3...
Post by: caladin on June 10, 2009, 08:23:57 PM
Sorry, I was rushing to get it posted before bed :)

My Controller board is one of these,with the dynamo motors he sells.
IT connects over the printer port.

Here's the process I followed to get to my current position.(Sorry it's long winded, hopefully it'll bring us up to speed)

Built a baby $100 router, installed electronics & motors got them working and moving over parallel port with supplied testing software from electronics vendor (stepper world).
Installed mach 3, got it working and cutting virtually.
Purchased copy of Mach 3.

Had "no motor movement issue" (just like now), tried to diagnose with website help (from here), didn't' work.
One of the guys offered to call me and walk me through fixing it, and it started working after the first or second thing he tried (Thanks again Chip!).
I sat amazed at how quickly it was fixed, watching it twitch and whir.
It was now cutting, real shapes out of wood, but because I used cheap all thread and nuts, I had tons of problem getting it to run smoothly.
About this time the the parts started arriving for "the big router" that used real 5 start acme screws & anti backlash nuts, so I stopped working on the little one.
Started building "the Big one".
Alas thrust washers are totally on back order! Doh!
Winter is over before they arrive, no time to finish.

Frame with no motion installed sits in garage staring sullenly at me for months on end.

After a long hiatus, I finally got back and finished "the big router" that uses the same electronics and motors as the little one, except with a 4th axis used to double the x.
I got the electronics all wired up and got it working with the supplied testing software from I had motion on all 4 axis' in both directions.
Running all software on the same computer I had working from before.
I then loaded my old Mach 3 xml file, set the ports and pins for the 4th axis and the the limit switches and expected to be finished.
All Limit switched currently set to inactive to simplify debugging.
Started it carving the roadrunner with the z to high to cut, and got nothing... not a twitch.

The motors all work over the same parallel port using the simple testing software, so it's clearly something that I've failed to do properly in setting up Mach 3.
My reset has to be toggled each time I start mach 3 and I do this before loading a G-code file.
Mach 3 behaves as if it is cutting, I can see the movement on the position monitors and watch the cut path being followed.
My machine has crappy scores in Drivertest.exe but Chip said it just means the router will slow down and speed up with mouse movement and I can put off replacing the Box till later.
On the diagnosis screen I have numbers for pulse frequency, though they bounce all over the place 4- 5 digits.

I loaded the diagnostics, or trouble shooting screen, and watched the Parallel port Pins indicator 'lights' to see if Mach 3 thought it was sending data over the parallel port. No lights are flashing.

Mach 3 is set up on the same port that the software is functioning correctly over.(0x378)

Any help or hints are greatly appreciated.

Title: Re: motors no go in mach 3...
Post by: Chip on June 11, 2009, 03:15:46 AM
Hi, Eric

I sorta remember talking with you back in January, I still have your # and I'll try to give you a call if I see you on line hear.

In the mean time, Hear are a few thing's to try,

In port's & pin's set to Sherline 1/2 step Mode and try setting "All" the "Motor Output's",  "Low Active's" to "Checked", If that doesn't Help change them to "X"'ed and give it another Try.

On the Diagnostic Page, The "Led's" just under "Port 1 Pin Current State", Won't Show any Output's for Axis Movement's at All at this Time, So it's not a good indication of what's going On., ( It's caused So Many Issue's / Confusion over Time for "New User's" it's Scary).

Give it a Shot and let us know.

Thanks, Chip
Title: Re: motors no go in mach 3...
Post by: caladin on June 12, 2009, 01:20:05 AM

Thanks for the help again Chip!

I've got motors turning.

After I hung up, i noticed that my 4th axis was not turning though.(it was behind me and i didn't see it just heard each axis move)

I RTFM and found the Slaving panel and set it to be slaved to my x axis,
as its supposed to. but when I Jogged the X and the 4 buttons no motion.
The pins are correct, and the rest is set up just like the other 3 axis.

The 4th axis moved under the test software.

I'll dig into the board manul and see if there is a separate disable/enable for the 4th axis,
but anyone has any other hints I'd love to hear them.


Title: Re: motors no go in mach 3...
Post by: hollyfox on June 13, 2009, 09:02:40 AM

What was the problem? I have a similar problem and wonder if something you did will help me.

Thanks Hollye
Title: Re: motors no go in mach 3...
Post by: Chip on June 13, 2009, 09:36:05 AM
Hi, Hollye

His disable/enable pin 14 wasn't setup to Enable1 Output in Mach.

Title: Re: motors no go in mach 3...
Post by: hollyfox on June 13, 2009, 11:24:05 AM
Oh, OK Thank you.
Title: Re: motors no go in mach 3...
Post by: caladin on June 13, 2009, 02:04:13 PM
Yet 14 was set to enable.

If you're having a similar issue, chip recommended to me to start by turning 1/2 pulse mode on, and leave it on till things are working before you try it with it off.
some boards need more time to sense the pulse and Sherline mode makes it go slower.

If you want to see how I set these settings in Mach 3, go here:
(copy and paste the link, the site is not setting it up correctly to just click)!+it%27s+(sorta)+alive!

Where I'm keeping track of progress lately. It's not fancy it's most there so i can keep track of what I've changed
So that if i have these troubles again, kind of like a diary.

It includes pics of the screen and where to set the settings I've mentioned so far.

Re my slaved axis issues, I checked the manual, as I remembered (2pp) there was only a master enable, which is on (now)
and I've set the slaving, so I'm still fiddling with it hoping to get the A axis working and slaved to the X axis.

I turned it off Sherline 1/2 step mode and everything (else)  seemed to run fine.

Title: Re: motors no go in mach 3...
Post by: hollyfox on June 13, 2009, 05:16:09 PM

Thank you for the info. I only have three axis and I found a reference on one of the other threads that indicated that uninstalling the parallel port and letting Windows reinstall it many times solves the problem. I am going to give this a try this evening if I get time and, if this does not work, I will try the enable and Sherline toggle. Somehow I have to get this thing going.

Thank you for your help. I will let you know how it goes.

Title: Re: motors no go in mach 3...
Post by: caladin on June 13, 2009, 05:34:50 PM

Chip had me download the parallel port monitor, here.

and see if i was getting activity on my port.

If you think the port is the issue, I'd download this and get the port working,
you can see activity on the port as the "lights" flash on the app.

There is a setting to made it stay on top so you can see it while other applications are running.
I don't' remember where it was exactly but i found it after a few tries.

If you can't find it, let me know.

If you need more info about parallel port stuff and diagnostic tools, I found this site helpful.
I'm a fairly technical PC guy, even if I'm a complete Newby to CNC, but it was useful.

As to my Issue, I figured it out it was an   Id10t Error, my Dir and step pins were reversed in the
port config. all 4 axis are working fine now.

Thanks for the help everyone!

Title: Re: motors no go in mach 3...
Post by: hollyfox on June 14, 2009, 08:12:23 AM

Thank you for the link. I actually found one yesterday just before you posted this at

I did some work last night (I work the weekends 12-hour shifts) and can see the direction pins toggling. I even see the 5vdc on the controller end of the cable. All of my pins are set up correctly in pins&ports since I have a printout of the Mach3 setup windows with the correct ones on it.

I am at a very odd stage now. The controller is comprised of three separate drive boards, one for each axis and I have tried to isolate it to a specific board or motor to no avail. I have also checked the voltage on the power supply and even checked it for loading during movement and it stays rock steady.

I am back to the possibility that something is corrupting the pulses from the computer (I do not have an o'scope to check them) so I am going to try one more thing...

I run an X10 controller on my powerline of the house and have decided to pull this off of the line to make sure that it is not throwing pulses on the powerline that are effecting the power supply of the controller.

I will let you know how it goes. If this does not work I will have to figure something else out.

Title: Re: motors no go in mach 3...
Post by: hollyfox on June 14, 2009, 09:11:03 AM
I think that I will double check this enable setting since I have found three posts where this turned out to be the problem. Is there any reason that this enable would change from the original other than one changing it?

Title: Re: motors no go in mach 3...
Post by: caladin on June 14, 2009, 11:27:35 PM

I don't know but i know that the same xml file was working 6 months ago when i
started building the bigger router, in 3axis mode with the same controller and motor.

I have to assume i did something, but I sure don't remember doing anything.