Hello Guest it is June 16, 2021, 10:55:30 AM

Author Topic: Noob is mystified  (Read 13418 times)

0 Members and 1 Guest are viewing this topic.

Noob is mystified
« on: April 22, 2009, 03:58:47 PM »
I'm new to Mach3 and can use some help.

I'm an experienced electrical engineer, embedded systems "guy", I design micro-controller based electronics, write firmware, Windows device drivers, dlls, applications, etc.

I have a small Dyna DM2200 machine in my basement, that I currently run with the electronics that it came with... they still work (1980s vintage)... believe it or not.

For those not familiar with the DM2200, it's a small benchtop 3-axis mill, stepper motor based, with it's own controller, and it's own programming language (Dyna proprietary, not g-code).

I'm interested in making the move to Mach3, and some sort of CAD/CAM software, to be more up to date.

I should be more than qualified to do this task (electronics and software wise)... but my machining knowledge is somewhat more limited.

Tapping into the DM2200 controls appears to be very easy, as the axis each have their own stepper drivers with STEP and DIR inputs, as well as home switches.

When the time comes... I will figure out distance per step, direction settings for each axis, and active states for the home switches.

So... the next step for me was to check out Mach3, and, for now, LazyCam.

I watched a bunch of the tutorial videos on the ArtSoft site, then I downloaded the latest lockdown version (Mach3 R3.042.020) from the ArtSoft web-site.

My plan was to just run Mach3 and LazyCam on my main computer WITHOUT installing the parallel driver or attempting to control any real hardware.

The hope was that those programs would run, I'd be able to experiment around with the example files (roadrunner, spanner, shapes, etc.) and get a feel for the apps before actually trying to control a real machine, or shelling out any money (though they are VERY REASONABLY priced).

I have had a lot of luck with this endeavor... but have also struggled quite a bit, and am now seeing something that i just can't figure out.

So here I am... asking for help.

Here's what I expected to be able to do:

1.  Run Mach3, without doing much of any setup, as it's in purely DEMO and SIMULATION modes (not controlling any real hardware).
2.  Run LazyCam, open the included dxf example files (roadrunner, spanner, shapes, etc.) view the toolpaths, generate g-code.
3.  In Mach3, see the resulting G-CODE from the examples, see the toolpath window, run the code (or at least the first 500 lines of it) in demo mode, and see the toolpath.

As I am doing this with the example files that came with the demo... I expected it to work, without much in the way of "gotchas" or strange unexplainables.

It's close.

I am absolutely able to run Mach3 and LazyCam.

I see the geometries of the example dxfs in LazyCam, and am able to generate G-Code into Mach3.

This is where things quit going so smoothly.

Apparently, due to the 500 line limitation in Mach3 (demo mode), and the fact that most of the example files generate more than that... I don't see what I was hoping for in Mach3, full geometries in the toolpath window.

I get partials... for instance... I see part of the Spanner Wrench.

I understand why this happens... and I could live with that... were it the only problem.

For evaluation, I tried reducing the size of the examples (let's talk about spanner) by deleting the 2nd chain, leaviing just the small oval from the left side of the spanner.

Now the geometry displayed in LazyCam and the ToolPath window of Mach3 match... and the G-code is well under 500 lines.

If I click on the first line of the G-Code, then slowly scroll with my wheel (mouse), I see the white highlights in the toolpath window, as expected (very cool).

This is where things quit going so smoothly (again).

Ok... here we go... pressing the start button (already cleared with reset).

Remember... I'm just simulating here... no actual machine... and this IS an example file... I've alread scrolled through the g-code and toolpath window looked good.

I expected to see Mach3 run through the G-code, executing line by line, while updating the DRO's and displaying the toolpath motion in the toolpath window.

That's not what I get.

It seems to jump through the g-code to the first line containing a G3... and then, in the toolpath windows, starts drawing these big green circles that don't seem to be in any way related to the part geometry.

First one in one direction, then one in the other direction, then a larger one, then an even larger one... then more on the opposite side of the origin... it's weird.

Stranger yet... it seems to do something very similar, regardless of what example file I have loaded.

My thinking right now is that this is happening either because:

1.  It's the demo... no license (but the other posts on this forum seem to indicate demo is FULLY functional up to 500 lines).
2.  It's because I didn't install the parallel port driver, and am runnning as a pure simulation (my guess).

If this is a demo issue... hey I'm more than happy to shell out the $175.00 for Mach3, the $75.00 for LazyCam Pro, and even the $50.00 for the "Mach3 addon's for Mill", as I said, all very reasonably priced.

If it's a simulation issue... I guess that means I have to either install the parallel port driver (not going to happen on my main P.C.) mabe even do a full-on hardware implementation with the actual interface to my mill.

At any rate, I guess I'm a little dissapointed that the example dxfs don't actually seem to work very well in demo/simulate mode... seems like that would be an obvious  goal for evaluation purposes.

I'm hoping somebody out there knows the deal, and can tell me... "go here and click on this and that, and then it will work".

Best regards,


Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Noob is mystified
« Reply #1 on: April 22, 2009, 04:13:47 PM »
Dont think you should need to install the driver to use in simulation, I have certainly used it that way before although normally I just install it, is there a reason you dont want to instal it?.
 Can you attach both the code and the xml for the profile you are testing. The xml will be in C:\Mach3 and if its the standard Mill profile you use it will be called Mach3Mill.xml. You will need to copy it to another loacation on your drive then rename before the forum will accept it, suggest you rename techsol.xml

Re: Noob is mystified
« Reply #2 on: April 22, 2009, 04:15:31 PM »
In "Config/general config" is IJ Mode Absolute or Incremental? Being set wrong would cause the large circles.

Offline Jeff_Birt

  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Noob is mystified
« Reply #3 on: April 22, 2009, 04:34:06 PM »
I converted a Dyna 2400 a few years ago to Mach control. It is just a slightly 'newer' machine than the 2200. I pulled out the distribution board and made my own opto-isolation board to fit the same geometry and that the stock wires would plug into. This worked well but the phase jitter from the LPT port driver combined with the stock stepper drivers left with with a max traverse speed of 10 IPM. Just last week I tired it with a SmoothStepper instead and got the rapids up to 30 IPM.

If I had it to do over again today I would use the SmoothStepper and a Gecko G540 driver. Neither were available when I did the machine. The Gecko G540 is nice as it has the optoisolation built in, among other things. It would have made the whole job much easier.

The 'crop circles' you describe are a classic symptom of the IJ mode being configured wrong (as others have stated.)
Happy machining , Jeff Birt

Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Noob is mystified
« Reply #4 on: April 22, 2009, 04:36:18 PM »
Surely crop circles would show in the toolpath view when loaded, also when scrolling through the toolpath and not just when running?

Offline Jeff_Birt

  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Noob is mystified
« Reply #5 on: April 22, 2009, 04:52:12 PM »
I'm not sure Hood, that could be. Maybe he can post the file here so we can try it. I also vaguely remember Brian saying something about the simulation mode using a completely different 'driver' (in other words not the LPT driver) perhaps this simulation 'driver' is getting confused?

By the description of the problem it sure sounds like crop circles though.
Happy machining , Jeff Birt

Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Noob is mystified
« Reply #6 on: April 22, 2009, 04:54:46 PM »
That too was my first though Jeff, but when he said that he could scroll through the code and watch the white line move round correctly I  reckoned it couldnt be that as any time I have seen it toolpath display showed them just after loading the code.
Re: Noob is mystified
« Reply #7 on: April 22, 2009, 07:31:51 PM »

That's great, people actually responding, I'm delighted!

Ok... about 6 replies to my original post, I'm going to try and respond to all here.

First off, for Hood, during the installation of Mach3 I got prompted for setting up a profile.

Being somewhat unclever... and knowing the CNC I will eventually try to control is a DYNA DM2200... I typed in "Dyna" and the install created a shortcut on my desktop called "Dyna" (as well as one called "Mach3 Loader").

I'm assuming the install used all the default settings in creating the Dyna profile.

So... the profile I'm using is called "Dyna", and I've been changing settings quite a bit trying to make this work, as evidenced by the 17 different versions of Dyna in my xmlbackups directory.

Unfortunately, I'm also new to this forum and now need to figure out how to post the file.... ahhhh, under additional options... got it.

Ok, I've renamed my "Dyna.xml" file to "techsol.xml", as directed, and attached.

It should be pretty much as created... though I did try changing a few things (like soft limits to make the table area bigger... as I originally thought that was why the spanner example was getting clipped).

In the interest of keeping things simple...  I'm going to use an unmodified version of the "AOuterProfile.dxf" example file for the followng... as it's small enough to work in demo mode, and it produces the same sort of problems as the other example files.

Everyone should already have that same dxf, as it came with Mach3 and is in the LcamSamples sub-directory of your Mach3 installation.

I simply load the dxf into LazyCam (selecting the "Mill" button), press the clean button, then the Postcode button, and then go back to Mach3.... where the gcode has been automatically posted.

I'm able to then scroll through the G-code listing, and I see the white highlight in the toolpath window... first on the rapid move, then on the vertical line on the far right, then on the arc on the bottom right, then on the horizontal line at the bottom, etc.

I've attached a screen capture of my Mach3 screen while scrolling (scroll.jpg), hard to make out the toolpath window, but you can clearly see the white highlighted arc.

As far as the IJ settings go... it was originally on abs, and I tried changing it to inc, and back again... same basic result, but the crop circles are larger and draw slower when IJ is set to inc.

Ok... I just noticed something that I hadn't before...

Besides the "Cycle Start" button, there is also a "Simulate Program Run" button.

Up until now, I've been clicking on "Cycle Start", that's where I'm seeing the "crop circles".

When I click on "Simulate Program Run"... the ONLY things that happen is the area between the "Simulate Pogram Run" and "Run from Here" flashes red, the gcode display jumps to line N65 almost immediately, and the "Estimated Program Run Time" counts up to  23:23.

If I then change my config IJ setting to inc, and do it again... same exact thing... immediately to line N65, stays there the whole time run time counter counts up to 23:23.

I get the feeling the "Simulate Program Run" is more about estimating run-time.

If I click on "Cycle Start" (IJ = ABS)... the gcode window immediately goes to line N50, the X DRO is slowly counting up, Y DRO is slowly counting down (even though line N50 clearly show a Y val of 0.000) and I get the beginnings of a large counter-clockwise arc from the origin.

I've attached a screen capture (start.jpg) of this that I took while it was running... not completed, as it's VERY SLOWLY drawing in the toolpath window, but you can clearly see the DRO's and the beginning of what will be a BIG circle.

Thanks to Jeff for the info on his Dyna 2400 conversion... interesting.  I had already looked at both the SmoothStepper and the various Gecko stuff (G100, and the various individual drivers).

Thanks to all of you for your various responses.

I get the feeling what I'm seeing is completely related to the lack of a driver... I can tell that Mach3 is a very widely used, very functional application, so I'm looking for "what am I doing different" which has got to be the lack of the driver.

The reason I didn't want to install the driver on this P.C. was because this is my MAIN get things done, write code, draw schematics, layout circuit boards, balance my checkbook, get my email... P.C..  The driver... doesn't seem like something I would want on this P.C.

But... it's the P.C. I have running today... has the most up to date hardware, biggest monitor, most memory, and... I WANTED TO PLAY WITH MACH3 AND LAZYCAM WITHOUT FURTHER DELAY!!!

I should probably just set up another P.C., install the driver, and try this all again.... hopefully sparing everybody further posts from this noob.

Best regards,

Re: Noob is mystified
« Reply #8 on: April 22, 2009, 09:02:42 PM »
Well it looks to me like you have things set up in metric but some setting is trying to run the code in inch.

Offline RICH

  • *
  •  7,419 7,419
    • View Profile
Re: Noob is mystified
« Reply #9 on: April 22, 2009, 10:41:24 PM »
I have installed MACH on numerous PC's, as an example, two at work for playing around / simulation, and never experienced any problems or interference with other programs. So not sure of your reluctance to installing it on your "main" pc but that's your choice. There is no problem removing it should you so desire. Just thought i would mention this.