Hello Guest it is May 23, 2019, 05:57:50 AM

Author Topic: Softlimits  (Read 43015 times)

0 Members and 1 Guest are viewing this topic.

Re: Softlimits
« Reply #50 on: October 19, 2006, 11:16:00 AM »
Joe

What are you doing when you get the warning in X and Y, I ask as when I've tested the softlimits I've not had any problems with the X and Y since version RC2.0d but my table is quite large for the job's I do so I might not have noticed it.

Do you use tool offsets? When ever I use tool offsets I get warnings for Z max/min or don't get warnings and proceed to go on to the softlimit. This is in the Version R2.0.001, I'm interested in what version you are using, if you are using tool offsets and they are working.

Cheers

Chris
Re: Softlimits
« Reply #51 on: October 19, 2006, 05:50:17 PM »
The softlimit warning pops up when you hit cycle start,I am using tool offsets and fixture offsets.This is a full size bridgeport cnc.I reloaded r1.84
and the softlimits work perfectly,just like a regular cnc,but any version after that will give you the warning,even 2.003.It doesnt stop you from running,you just have to click the balloon every time,thanks for you help,Joe.
Re: Softlimits
« Reply #52 on: October 20, 2006, 07:20:14 AM »
Joe

Version R1.84 doesn't have the softlimit warning messages in at all, it's a new feature I've been trying to get Brian and Art to add but it's only included in versions D1.90.090 onwards and so far it's not fully working but they are getting there.

Art

I've just tried Version R2.0.003 it seams to me like the tool offset are the wrong way around again, or maybe the have allways be the wrong way around. I also tried a old program that I know works well and I got a softlimit warning on X max, I know it doesn't exceed the limits and I can see on the toolpath screen that it doesn't exceed the limits, I've tried to get my test program to throw the same error up but I can't so I can't quite work it out.

I'm also having trouble using cutter compensation with the last 2 versions, it allmost like the Y codes have become non modular (I think thats the right word), I had to put a Y value into every line after a G42 to get my test program working.

Thanks

Chris

Hood

*
Re: Softlimits
« Reply #53 on: October 24, 2006, 03:59:17 PM »
I have just started getting the softlimits warning, this is with the latest version 2.0.004. I didnt get it with any of the previous versions so I dont really understand whats going on.

Hood

Hood

*
Re: Softlimits
« Reply #54 on: October 25, 2006, 03:59:39 PM »
The latest version 2.0.005 has cured the softlimits error message for me :D Have you tried it yet Chris?

Hood
Re: Softlimits
« Reply #55 on: October 26, 2006, 06:19:15 AM »
Yeah I've tried version 2.0.005 and I'm still having trouble with the tool offsets and now X and Y, have a look at the screen shot below, it shows how far away I am from the soft limits but I'm still get a warning. :o

Hood if you put a tool offset in, large enough too send the machine on to it's limits do you get a warning?

Thanks

Chris

Hood

*
Re: Softlimits
« Reply #56 on: October 26, 2006, 04:37:59 PM »
Chris
 not sure what you are meaning, radius comp or length offset? Also version 2.0.005 was changed without a version update, have you tried downloading it again?

DrStein
 Limits are there to stop the machine if they are triggered. If yours dont stop your machine they are not set up right. If you press them manually does your Reset button start flashing? do you get the LEDs for that axis lighting on the diagnostics page?
Hood

Hood

*
Re: Softlimits
« Reply #57 on: October 26, 2006, 05:24:08 PM »
Well if the LED is working the limit is obviously being seen by Mach, can you post a screenshot of your PORTS AND PINS, Input Signals page? Or possibly post your xml.

BTW when you sat the LED is working, which LED lights up?
Hood

Offline chad

*
  • *
  •  361 361
  • When the going gets weird, the weird turn pro.
    • View Profile
Re: Softlimits
« Reply #58 on: October 26, 2006, 07:06:23 PM »
Are you using 1 switch for BOTH homing and limit?

Or do you have 2 switches, one for home and another for limit?

Chad
Re: Softlimits
« Reply #59 on: October 26, 2006, 07:50:50 PM »
Hood

I meant the tool Length offset, I'm not sure what you have got your softlimits set to but I guess they will be about the same as mine with it been the same machine, anyway try this if you would please.

Set G54 Z offset to -200 & T3 to +200, this is presuming your soft limits in Z are roughly from 0.0mm to -127.0mm, then run this.

%
G21
G0G17G40G49G80G90
T3M6
G0G54G90X0.Y0.
G43H3Z-1.
G1Z-10.F1000.
M30
%


When I run it I get a Soft warning on Z min. Just want to make sure it not just me.


Quote
Also version 2.0.005 was changed without a version update

I'm glad you said that, I been having trouble with cutter comp and Art kept telling me it was ok on his so I've just totally uninstalled and reinstalled Mach 3 and it the cutter comp works again, I guess that explains why it wasn't working before.

Cheers

Chris