Hello Guest it is October 16, 2019, 11:44:08 PM

Author Topic: Help with Homing/Limits  (Read 2821 times)

0 Members and 1 Guest are viewing this topic.

Help with Homing/Limits
« on: February 18, 2009, 02:54:12 PM »
Hi,

My machine has two motors on my X; the A is slaved to my X.  All works well when jogging and cutting.

Today I decided to setup my limit switches.  I'm using a PDMX-122.  I used pin 11 and ground with Normally opened parallel switches.  All works well so far.

I set X++, X-- and X Home to pin 11 Active Low.  Switches work fine in diag window.

In the MotorHome/Soft Limits section I select Home Negative and Auto Zero to checkmarks.

When I try and to a home, it appears like only one of the motors on the X is actually turning, the other one tries to skip the rack (spring loaded).

Do I have to set another limit for the A-Azis (slaved axis) to work in tandem with the X-axis?  Is there another setting that I am missing?

(jogging and normal cutting work great)

Any help appreciated.

Thanks, Greg

Offline Greolt

*
  •  956 956
    • View Profile
Re: Help with Homing/Limits
« Reply #1 on: February 18, 2009, 03:50:39 PM »
Greg

On the general config page set "Home Slave with Master Axis"

Another Greg
Re: Help with Homing/Limits
« Reply #2 on: February 18, 2009, 06:13:09 PM »
Ahh,

I knew I was missing something! 

I went and put both motors on the same signals from the PMDX122 and that also worked as well (Gecko 203's).  Getting a nice home with de-bounce happening.

Thanks Greg, Greg