Hello Guest it is October 19, 2019, 01:54:22 AM

Author Topic: Tool information not displayed.  (Read 4084 times)

0 Members and 1 Guest are viewing this topic.

Tool information not displayed.
« on: December 21, 2008, 04:46:28 AM »
Can anyone suggest a reason why I cannot get the tool information panel to display the tool number and offset value. Should this panal be pink in colour with a licensed version of Mach3.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Tool information not displayed.
« Reply #1 on: December 21, 2008, 05:06:13 AM »
Is this Mill or Turn and is it the standard screenset? Can you attach your xml so I can test here.
Hood
Re: Tool information not displayed.
« Reply #2 on: December 21, 2008, 05:29:17 AM »
Hello Hood, it is Mill I am trying to use. I have licensed it and my name displays in the license box so I think I have done that right. What is this XML that you wish me to copy ?? Oh yes it is the standard screenset I am using.
« Last Edit: December 21, 2008, 05:31:10 AM by Hillbilly9749 »
Re: Tool information not displayed.
« Reply #3 on: December 21, 2008, 05:41:12 AM »
Hi again Hood.
                    The program I am trying to test is copied below. It also seems that the DRO does not recocnise that either tool lengths or cutter comp is being used because the read outs are exactly as programed. I would have expected the Z read outs to be the programed position plus tool length and the X/Z to be greater by the amount of cutter comp.


M0
G80G40G21G90G00G17
(HILLBILLY SHADY SHALLOW BODY)
(7 DIA BALSA 21MM OUT OF COLLET DRILL/PUNCH 1.5 DIA)

T0M6
(GRIND END FLAT)
N10
G54G90G00X30.Y0
G43Z20.H1
G00Z1.5
G01X20.F200.
G00Z20.

(DIMPLE PUNCH)
N20
G00X50.Y0
G43Z10.H2
G81Z-5.R2.F1500.
G80
G00Z20.

(PUNCH BODY)
N30
G00X-50.Y0
G43Z10.H3
G81Z-26.5R2.F1500.
G80
G00Z20.

(SHAPE BODY)
N40T4
G00X20.Y0
G43Z60.H1
G00X10.Z10.
G01G40D1X0Z3.F1000.
G01Z0F50.
G18G03X0Z-16.R10.F300.
G00X20.
G01G40X22.Z-18.F1000.
G00Z250.
M30



Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Tool information not displayed.
« Reply #4 on: December 21, 2008, 06:03:23 AM »
OK first I am presuming this is Mill you are using? Second I am not great at G Code but first thing i see is you dont have the M6 for the tool change. Also not sure if you can have a Tool 0.
 Please attach your xml and your tooltable, the tool table is in your macro folder then in the profile you are using, its called Tool3.dat
You will need to copy them to a different location on your drive and rename before the forum will accept them.

Hood
Re: Tool information not displayed.
« Reply #5 on: December 21, 2008, 07:30:40 AM »
Hood I do not know what this XML is you speak of and cannot open the macro folder in Mach3.exe. Just do not know what to try next as I have run program with and without tool changes and with TI as tool in spindle via auto tool change mode. May have to remove and re instal Mach as I am running out of ideas.
« Last Edit: December 21, 2008, 07:32:11 AM by Hillbilly9749 »

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Tool information not displayed.
« Reply #6 on: December 21, 2008, 08:54:41 AM »
Ok the xml is a file which is located in the folder you have installed Mach to, usually C:\Mach3.
There are several xml's there but the one you want is for the profile you are using, for example if you are using the default Mill profile it will be named Mach3Mill.xml, if you have made a custom profile it will be the name or your profile.xml.
 The macro folder is also located in the C:\Mach3 directory and when you open that you will see more folders, go to the one of your profile (Mach3Mill or whatever) and you will see the Tools3.dat there.
As said above you will need to copy both fles to for instance your desktop and rename them before the forum will accept them, suggest you call them Hillbilly.xml and Hillbilly.dat.
 To attach the files you use the aditional options button on the reply page then browse to the loacation of them on your drive.

Hood
Re: Tool information not displayed.
« Reply #7 on: December 21, 2008, 09:51:00 AM »
Hi Hood, I have looked and only the macro folder seems to be there and that will not open. I have decided to delete mach3 completely and start again to see if that works. :(

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Tool information not displayed.
« Reply #8 on: December 21, 2008, 09:53:57 AM »
Make sure you dont have two Mach3 folders, an earlier version (maybe more than one) installed to Mach 3 instead of Mach3.
Hood
Re: Tool information not displayed.
« Reply #9 on: December 22, 2008, 12:31:36 PM »
The re load has worked with tool number and its dia+length now shown in the display. Thanks Hood and everyone for trying to help.