Hello Guest it is April 19, 2021, 01:30:42 AM

Author Topic: Any one tried a MPG with the PoKeys?  (Read 9171 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Any one tried a MPG with the PoKeys?
« on: December 02, 2008, 04:39:15 PM »
I fitted up my pendant the last day and the MPG worked after a fashion, as long as I didnt wind too fast it was fine, if I wound a bit to fast it would just stop responding.
Anyone else tried it?

Hood
Re: Any one tried a MPG with the PoKeys?
« Reply #1 on: December 03, 2008, 05:09:39 PM »
Hi Hood,

I'm interested in a Pokeys for use on an Orac conversion project. I need the MPG for X & Z handwheels so I can use the machine CNC or manual "fly by wire".
So if anyone has had sucess, I'll def order a Pokeys.

ATB

Derek,

You can "chop it off" but can't "chop it on"

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Any one tried a MPG with the PoKeys?
« Reply #2 on: December 03, 2008, 05:34:58 PM »
Derek
 It does work, just its not as good as the parallel port for normal use, the step use is much better on the pokeys than the parallel port however.
Hood
Re: Any one tried a MPG with the PoKeys?
« Reply #3 on: December 31, 2008, 02:35:11 PM »
How should I configure MPG in Mach3 ? I have it working OK in PoKeys-configuration software, it's showing values from 0->254 just ok. But when I tried to use MPG #1 in Mach3, it outputs strange values (tens of thousands of clicks per one unit) to the MPG calibration screen. Something I'm missing. I don't have any Brains configured for MPG-input, I'm using Brains just for analog FeedOvrd for now.

With best regards from Finland & Happy New Year !

Henry "Henkka" Palonen 

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Any one tried a MPG with the PoKeys?
« Reply #4 on: December 31, 2008, 03:34:44 PM »
Hi Henry

 You just configure like you would a normal MPG, then use the calibration wizard to set it up correctly. Mine works fairly well via the PoKeys but if I wind too fast then it will just stop any motion until I wind slower, seems to be the plugin doesnt read the data fast enough. As you say the PoKeys software itself seems to have no problems reading the MPG. I am not using the PoKeys at the moment as I am rebuilding my pendant but unless there is an improvement in the speed response of the MPG via the PoKeys plugin then I will just use the SmoothStepper inputs for it.
 Have you enabled the MPG in the Plugin?
Hood
Re: Any one tried a MPG with the PoKeys?
« Reply #5 on: December 31, 2008, 03:47:08 PM »
It's working ok now. I restarted the machine & Mach and did some other button-configurations in the meantime.

Here is the configuration I'm using for PoKeys55T MPG:

1) In Config->Ports & Pins ->MPG config;
1a) enable, A-port = 10, A-Pin = 1, B-Port = 10, B-pin = 2

2) "Plugin Control"-> "PoKeys Conf" -> "Use Encoder5 - MPG1" is checked

After that it seems to work OK, albeit little slow. I can't judge yet how actual milling machine will perform,
since I'm running Mac OS X and on top of that VMWare virtual machine where the Mach3 & PoKeys is run in the Windows-machine. There might be some
lag issues due to my machine setup. As soon as I wire the rest of the buttons & configure the PoKeys, I'll transfer the setup to the actual workshop-machine.

With best regards & Happy New Year from Tampere / Finland,

Henry "Henkka" Palonen


Thanks for your quick reply.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Any one tried a MPG with the PoKeys?
« Reply #6 on: December 31, 2008, 03:50:38 PM »
Henry, what date is the plugin you have? The earlier ones had a fair bit of lag, the one I am using is dated 22/11/2008

Hood
Re: Any one tried a MPG with the PoKeys?
« Reply #7 on: December 31, 2008, 03:54:28 PM »
Yes, the date is same. I got the plugin from PoKeys homepage, that had same date as that post had (the post where the new plugig was attached).

Henkka

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Any one tried a MPG with the PoKeys?
« Reply #8 on: December 31, 2008, 03:57:44 PM »
Please let me know how it works out for you, as I siad it seems to work every bit as good for me as the one via the parallel port (actually SmoothStepper now) with the exception that if I wind too fast it stops responding.
Hood

Offline Don C

*
  •  25 25
    • View Profile
Re: Any one tried a MPG with the PoKeys?
« Reply #9 on: February 11, 2009, 07:47:21 PM »
What MPG are you using with pokey55.
 Thanks
  Don :)