Hello Guest it is March 05, 2021, 08:56:42 AM

Author Topic: Rapids change spindle speed  (Read 5313 times)

0 Members and 1 Guest are viewing this topic.

Rapids change spindle speed
« on: October 31, 2008, 07:06:40 PM »
Hi All,
I've recently retrofitted an ORAC lathe with new electronics, running it with MACH3. I'm pretty much there - turned a great 90deg radius! but....
I've noticed that with the spindle running, rapid jogging the Z axis causes the spindle to speed up. It slows to its original speed when you stop jogging. Now while not a major problem, this also shows when thread cutting, which may be the reason I've failed to cut anything like a clean thread.
I'm sure it's a configuration problem, though I've not found it. Turning CV on/off does not have an effect.
Any pointers gratefully received!
Paul
« Last Edit: November 01, 2008, 05:28:31 AM by frogeye »

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rapids change spindle speed
« Reply #1 on: October 31, 2008, 07:45:17 PM »
How is your spindle controlled? Try increasing the pulse width in motor tuning to 5. What version Mach are you running, for threading with a weak spindle motor you really need to use the latest development version as a lot of work has been done on threading lately. Be aware however that it is a development version so some things may not be perfect , however I have been using it for a while now and I think its the most stable yet :)
Hood
Re: Rapids change spindle speed
« Reply #2 on: November 01, 2008, 05:33:01 AM »
Hi Hood,
I'm using MACH ver 3.041 and spindle control is via a C11G breakout board and Mitsubishi FR-D720S inverter.  If memory serves, the pulse width for the spindle is currently 1, so I'll try that first.
Many thanks,
Paul
« Last Edit: November 01, 2008, 05:57:54 AM by frogeye »

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rapids change spindle speed
« Reply #3 on: November 01, 2008, 05:46:55 AM »
I think that may well be your problem, have never used CNC4PC stuff myself but I think I remember seeing that it needs quite a wide pulse width.
Hood
Re: Rapids change spindle speed
« Reply #4 on: November 01, 2008, 09:46:19 AM »
OK, a bit more information

Tried increasing pule width for spindle to 5mS. Needed to tweak the pot on the C11G up a tad to get full output, but other than that, no improvement.
I have noticed that this phenomenon is very controlled.
Spindle running at 800 rpm,  output to VFD from breakout board 4.00v, jog Z at 10% and speed and output from BB increase by 10%. This is so for other jog values up the maximum spindle speed of 2000 rpm.  ???

I've just tried this on the x axis, and the results are exactly the same. Does anyone else see this 'problem'... Is it the way MACH is designed to work??

Any suggestions gratefully received..as always :D

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rapids change spindle speed
« Reply #5 on: November 01, 2008, 10:13:43 AM »
I have seen people have this problem and all used the CNC4PC board, was sure increasing the pulse width cured it for them but maybe my meemory is not correct. Do a search and you may find the answer.
Hood
Re: Rapids change spindle speed
« Reply #6 on: November 01, 2008, 02:23:39 PM »
Thanks for your help Hood, it pointed me in the right direction  :)

Update......
Spent the afternoon trying to nail this.  Was able to try a different turn profile (xml file) and this did not exhibit the problem. After that, it was a case of comparing the two.  The parameter that was causing the problem (in this case) was found in Ports & Pins, Motor Outputs. Spindle dir lowactive was on and turning it off cured the problem. Just needed to tweak the motor tuning to get the right voltage out of the C11G.

Though why this caused the problem in the first place, I would love to know!

Cheers,
Paul

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Rapids change spindle speed
« Reply #7 on: November 01, 2008, 05:49:50 PM »
Great you found it :)
Some drives are fussy about the active  state of the Dir pin so it seems that you have also found that your spindle controller is as well.
Hood

Offline Roy

*
  •  16 16
    • View Profile
Re: Rapids change spindle speed
« Reply #8 on: November 01, 2008, 07:14:13 PM »
Glad you solved the problem.

I have almost finished converting my Triac with a CNC4PC board.  Trying mine tonight, I find I have this same problem (didnt notice before). I had a play around with the pulse width too, to no avail!

So I will try your solution tomorrow!

Cheers, Roy
1986 Denford Triac Mill running on Mach 3 Via CNC4PC breakout board.

Offline Roy

*
  •  16 16
    • View Profile
Re: Rapids change spindle speed
« Reply #9 on: November 03, 2008, 06:42:30 PM »
Just been playing around with the spindle set up on the triac tonight. (brown & pestall inverter on cnc4pc c11 bob)

I have found on my set up I need to set the pulse width to 5 in order to stop the spindle speed altering with axis or mouse movements.

However i am now struggalling to 'calibrate' the spindle. It is fine at all other pulse widths, but set at 5 I have 150rpm fast at 1000 rpm, and 100rpm slow at 2500.

Any ideas as to the problem??


Thanks, Roy
1986 Denford Triac Mill running on Mach 3 Via CNC4PC breakout board.