Hello Guest it is July 05, 2020, 05:12:09 PM

Author Topic: Xylotex to Gecko G540  (Read 5295 times)

0 Members and 1 Guest are viewing this topic.

Xylotex to Gecko G540
« on: October 26, 2008, 08:41:01 PM »
After a long run with no issues with a Xylotex controller the power supply blew and fried the board.  So I decide to try the new G540 module from Gecko.  So far I got it installed with no issues.  But now I have a few questions.

I am using two PACSCI Powermax II P22nrxd-ldf-ns-00 motors rated at 1.25A and 65V on the X and Y axis. My questions are:

1) There is very low torque on the motors.  When I used the Xylotex these had a LOT more torque when they were not moving then now with the G540.  I assume the only way to increase the torque is to increase the size of the resistor from 1.2k to something higher?

2) In the tuning window with the Xylotex the "steps per" was set to 8000 with the G540 I had to change it to 800, I used a indicator to figure this out.  That does no make sense to me since I did not change the motors.  But I could not find any information either way.  Just does not seem correct to me.

All help is much appreciated.

Thanks

Dan

Offline ger21

*
  • *
  •  6,280 6,280
    • View Profile
    • The CNC Woodworker
Re: Xylotex to Gecko G540
« Reply #1 on: October 26, 2008, 09:07:40 PM »
Increasing the current can damage the motors, so don't increase the resistor value. The G540 has a current reduction when not moving. If you move the motors, does it then have more torque after it stops?

Something is wrong with your setup. The Xylotex has a max setting of 1/8 microstep mode. The G540 is fixed at 1/10. So if your Xylotex was set to 1/8, with the G540 you should have 10,000 steps per unit. There's no way the steps per unit can be less than the Xylotex with the G540. You might want to call Gecko with your concerns. They should be able to get you set up pretty quickly.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Xylotex to Gecko G540
« Reply #2 on: October 27, 2008, 04:22:24 PM »
Fixed and everything works great.

I found that I needed to double the resistor to 2.5k because the wiring for the PACSCI motors are labeled as serial wiring and I was wired in parallel.

I had the native units in MM and the setting screen set in IN. Changed the native units to IN and set the steps to 10,000 and everything works great.

Thanks to all that offered advice.

Dan