Hello Guest it is November 21, 2019, 10:09:09 PM

Author Topic: still getting softlimits warning  (Read 4763 times)

0 Members and 1 Guest are viewing this topic.

Re: still getting softlimits warning
« Reply #10 on: October 22, 2008, 06:41:02 AM »
I included fixtures.dat and a screenshot of the offsets table. Thanks in advance. How do you ever get any real work done when you spend so much time helping out here?
Joe

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: still getting softlimits warning
« Reply #11 on: October 22, 2008, 08:29:47 AM »
Well thats probably the reason I never have any money ;D

Ok get the softlimits on Y when I use your profile/code.offsets. What I did notice though is it is only giving me the warning on the first run, after that it will not warn. What I then did was open Mach, Ref All and then typed G56 into the MDI line and then when I started the code I never got the SoftLimits warning. I dont use offsets much so have never come across this before but maybe the MDI before the offset is a clue to why its happening. Give that a go and let me know if you get the same.

Hood

Re: still getting softlimits warning
« Reply #12 on: October 22, 2008, 05:48:18 PM »
So it's not just me...
Maybe if I include the G56 and the linear move in the same line...
Usually G54 is active (work offset 1). I used G56 because I had another offset saved in G54. I likely won't use offsets other than 1 often so I can try the routine using G54 and see if I get the same results.
Joe